Question PC won't start. Multiple clicks, now nothing.

Sep 29, 2022
2
0
10
0
I woke up this morning and when I tried to turn on my PC I had no luck. Trying to turn it on caused the PSU to click multiple times (5+), all fans started as well as my mouse lit up but no display. Could not shut down PC without cutting power.

I then tried unplugging everything and plug it back in again, no dice, now it doesn't even seem the PSU is given a startup command my the MB. Nothing happens when I press the power button or short circuit the power pins.

I tried the paperclip test on the PSU, and it clicks when I do so however the fan does not spin up. (The click does not happen when I try and turn it on with the power button)

To me this seems to indicate a faulty MB, or could it be the PSU?
 
I woke up this morning and when I tried to turn on my PC I had no luck. Trying to turn it on caused the PSU to click multiple times (5+), all fans started as well as my mouse lit up but no display. Could not shut down PC without cutting power.

I then tried unplugging everything and plug it back in again, no dice, now it doesn't even seem the PSU is given a startup command my the MB. Nothing happens when I press the power button or short circuit the power pins.

I tried the paperclip test on the PSU, and it clicks when I do so however the fan does not spin up. (The click does not happen when I try and turn it on with the power button)

To me this seems to indicate a faulty MB, or could it be the PSU?
[/Q
I woke up this morning and when I tried to turn on my PC I had no luck. Trying to turn it on caused the PSU to click multiple times (5+), all fans started as well as my mouse lit up but no display. Could not shut down PC without cutting power.

I then tried unplugging everything and plug it back in again, no dice, now it doesn't even seem the PSU is given a startup command my the MB. Nothing happens when I press the power button or short circuit the power pins.

I tried the paperclip test on the PSU, and it clicks when I do so however the fan does not spin up. (The click does not happen when I try and turn it on with the power button)

To me this seems to indicate a faulty MB, or could it be the PSU?
That looks like PSU if it doesn't start it's fan at such basic test !
 
Sep 29, 2022
2
0
10
0
That looks like PSU if it doesn't start it's fan at such basic test !
Thanks for the response, I managed to dig up a second PSU. Connected the 24-pin and the 8pin cpu. That managed to start, tried the same with the other psu and no luck.

So it seems you are definitely correct that it is the PSU that is dead.

Tested the PSU again with the paperclip, it spins up for a second or two after a relay click then stops again. So to me it seems a part of it is short circuiting whenever it gets power?
 
Thanks for the response, I managed to dig up a second PSU. Connected the 24-pin and the 8pin cpu. That managed to start, tried the same with the other psu and no luck.

So it seems you are definitely correct that it is the PSU that is dead.

Tested the PSU again with the paperclip, it spins up for a second or two after a relay click then stops again. So to me it seems a part of it is short circuiting whenever it gets power?
It's dead Jim. :(
 

ASK THE COMMUNITY

TRENDING THREADS