Question PC won't start up after BIOS upgrade [gigabyte ga-z68p-ds3]

Nov 28, 2019
1
0
10
0
I wanted to change my i5 2500K for i7 3770 in by (old) mobo gigabyte ga-z68p-ds3
For that, I needed to update BIOS to latest version F9 (support for 22nm ivy bridge).
(after it, I had a lot of pain to set the up BIOS settings, because I think updating the BIOS, restored it's settings to defaults ??)

Now, even with my old i5 CPU, when I turn on the PC, it shuts down after some very short time (1,2 seconds), and enters this shut-down, turn-on loop.
When I leave only one RAM module inside, it can boot into OS.

I had that problem a month ago, when I was cleaning my pc, took GPU and RAM modules out, and when I returned them in, I had the same problem. Before I solved it by trygin to clean the modules and RAM sockets, and pulling them out and in again, and I solved it somehow, but this time - whatever i do, clean, reposition modules, etc. it just won't boot when I put all 4 RAM modules in the sockets.

Note: 2 RAM modules are some Patriot ones, with ~1600, and other two are ~1860 (cant remember the manufacturer, it reads something "Sniper" on them). But it used to work perfectly fine for 2 weeks, before I updated BIOS and pulled them out and in again.

Does anybody have any tips, please?
Thanks.

Disclaimer: I'm a software developer, and for years I was not into hardware world, and thus lost quite a lot of knowledge about it :)
 

ASK THE COMMUNITY

TRENDING THREADS