Question PC won't start

May 18, 2019
5
0
10
0
I just finished my first build and I went to go turn it on the the flash and spinning of all the lights in my build only to have it turn off. The CPU debug light came on but I've already tried reseating it and making sure everything is plugged in all the way. What could be wrong?
 
May 18, 2019
5
0
10
0
Please list full pc spec.
PC Specs

Case: White Corsair Carbide Spec 06
Motherboard: MSI z390 Gaming Edge AC
RAM Corsair Vengeance Pro RGB 3200mHz
CPU: Intel i7 9700k
SSD Samsung Evo 860 250GB
HDD: Seagate Barracuda 1TB HDD
COOLING: 3x Corsair LL120 RGB 120mm Fans
CPU COOLER: 360mm Corsair Hi500 PRO RGB AIO Liquid CPU Cooler with 3x more Corsair 120mm LL120 RGB
GPU: Gigabyte GeForce RTX 2080 Windforce OC 8GB
PSU: 750 watt 80+gold
 
Check the CPU Power Connections again. I am not familiar with that Motherboard, but with ASUS they have the socket right up on the upper left edge and it is really a nuisance getting the 2 4 pin plugs in. Not a lot of room to work in, and I have small hands. I should have taken the fan out in the top which would help. Where it is located, it is good for wire management. as the cable comes up from behind and over the top to plug in. Keeps it out of the case. Also check the 24 Pin ATX plug, but it would do anything if that was not plugged in properly.
 
May 18, 2019
5
0
10
0
Check the CPU Power Connections again. I am not familiar with that Motherboard, but with ASUS they have the socket right up on the upper left edge and it is really a nuisance getting the 2 4 pin plugs in. Not a lot of room to work in, and I have small hands. I should have taken the fan out in the top which would help. Where it is located, it is good for wire management. as the cable comes up from behind and over the top to plug in. Keeps it out of the case. Also check the 24 Pin ATX plug, but it would do anything if that was not plugged in properly.
I did all of that and it still doesn't work. If the debug lights glow for the ram and then flash to CPU and then turns off is it the CPU or ram?
 
May 18, 2019
5
0
10
0
I think i figured out my problem. MY mobo is running on old BIOS software as it was made it September 2018 and I just started to build my PC. But since I do not have Flashback + I have to get a new MOBO with the new bios
 
I think i figured out my problem. MY mobo is running on old BIOS software as it was made it September 2018 and I just started to build my PC. But since I do not have Flashback + I have to get a new MOBO with the new bios
That isn't bad. I have run them for years without updating / Flashing the BiOS. That shouldn't be an issue. If you want to get a new motherboard, then do so as you have to anyway if as DIMM slot is toast.
 

ASK THE COMMUNITY