News PC Won't Stay in Sleep Mode: Windows 10 Up Blamed

wmdavid.wallace

Prominent
Jul 7, 2018
2
0
510
0
I keep my PC right up to date most of the time. Recently I found that my PC would not remain asleep if I clicked on the sleep option however if I set my mouse on a nearby shelf and briefly used the power button (which on this system is set to sleep) then all was well. As best I can tell the slightest mouse activity wakes the machine. I tried setting my PC not to wake on mouse activity ( thru Device Manager as best I recall ) but that did not help. My mouse and keyboard are wireless Logitech devices. Not sure if this is the same issue you are seeing or not.
 
May 31, 2020
1
0
10
0
I keep my PC right up to date most of the time. Recently I found that my PC would not remain asleep if I clicked on the sleep option however if I set my mouse on a nearby shelf and briefly used the power button (which on this system is set to sleep) then all was well. As best I can tell the slightest mouse activity wakes the machine. I tried setting my PC not to wake on mouse activity ( thru Device Manager as best I recall ) but that did not help. My mouse and keyboard are wireless Logitech devices. Not sure if this is the same issue you are seeing or not.
Thanks @wmdavid.wallace ! I had this exact problem and it was driving me nuts. Your solution solved it.
 
Aug 10, 2020
1
0
10
0
Found out my LAN adapter would not let the machine sleep; it kept waking up. I check the adapter power settings and unchecked the wake on LAN...
 

frankanderson1

Commendable
Jan 26, 2018
3
0
1,510
0
Here is a few things I did and I never saw my computer wake up on its own again unless I wake it up.

Right click computer, Manage.
Go to Task Scheduler > Task Scheduler Library > Microsoft > Windows > UpdateOrchestrator
Disable Maintenance Install

Windows Search > Power > Power and Sleep Settings >
on the right side > Additional Power Settings
on your selected preferred plans > change plan settings
select change advanced power settings >
scroll down to Sleep > Allow Wake Timers > Setting: Disabled (default is enabled)

This will prevent windows update from waking up your computer / laptop from sleep mode at 4AM and applying a update. Laptop users should really do this as it can heat up your laptop if you have it tucked away or in a bag.
This will not stop windows from updating while it is on or you manually checking for updates.

Right click computer, properties. >Select device manager.
Under Keyboards and Mice and other pointing devices. (all of them)
In the Power Management Tab, Uncheck "allow this device to wake the computer".

under Human Interface Devices > USB Input Device, HID Complaint Device, HID Compliant Consumer Control Devices and HID compliant vendor defined devices > Power Management Tab > uncheck allow this device to wake the computer.

My logitech mice & Logitech KB doesn't wake the computer. My Glorious Model D doesn't wake the computer from movement, but clicking on the button wakes it. Your mileage may vary.



optional - under universal serial bus controller
optional - check all your USB Hub, names may vary depending on your boards USB chipset.
optional - power management tab, check "allow the computer to turn off this device to save power", default should be checked but there has been instances where it was unchecked by default.

If you have a lot of USB stuff attached, the optional portion may cause your USB devices to act funny after shutting off/on from sleep mode, particularly Elgato Stream Deck, remedy this by removing the check to "allow the computer to turn off this device to save power". eg; leave the hubs powered even during sleep mode. Your devices may still go to sleep while Windows is in sleep mode.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS