Question PC won't turn on after bios update

Jul 1, 2020
1
0
10
0
I'll post this here because problems started after BIOS update, but the whole PC don't turn on now and i can't find anything similar.

What happened
Yesterday i played some ark, my room got scorching hot and i wanted to adjust gpu fan spin, but i didn't have the software to do so.
So i went out of my way on MSI (full specs below) website to download some utilities and got myself the "dragon center" or something like that.
Played around with what i found (i only managed to change led colors though) and then i saw a BIOS update.
So without any research i trusted the manufacturer and went ahead and done it.
I've done it through their app, so i was confident all was well.
The application downloaded the software.
Rebooted my pc in a screen i've never seen before (never updated a BIOS), which was flashing the bios.
Reached 100% and then rebooted.
but
it never started again.

What i see
When i press the power button, nothing happens.
If i keep it for longer, say 10 seconds, nothing happens.
But the next time i press it, fan spins, leds turn on, but VERY briefly (say, 1/10 of a second), then instantaneously shuts down.

What i did to try and fix it
Browsed the Google Wonderland, only to learn that this issue seems unique, since in most of similar issues PC doesen't reach to POST, but my issue is waaay more extreme than this.

First thing that was suggested was to clear CMOS, but i don't have the jumper, so i tried with a screwdriver. But to do so, the pc must be running, or at least, can start.
So, just to be sure, i removed the CMOS battery altogether, left it off for 10 minutes and the put it back in, but nothing.

Tried fiddling with power button connectors on the mobo, but nothing, power button is fine.

I have a graphic tablet and noticed that its led was blinking even when PC was off, so i went ahead and disconnected EVERYTHING, now it's just the PC and the power chord. Still nothing.

Then i tried to plug off everything else (monitors and various other peripherals) to ensure enough current was delivered. Still nothing.

Removed one ram stick, then the other one. No changes.

My considerations
Pc was running just fine before the damn BIOS update, so i'm led to think that the BIOS is the issue here, but from the behaviour seems like an hardware problem.
It feels like a capacitor is broken either on the MOBO or in the PSU, i gave a look and didn't manage to find anything (on the MOBO, didn't dare to touch the PSU).
The most likely is that the BIOS now can't recognize the CPU, so it doesen't start.
Beside that, i'm out of ideas, was hoping for some help from you guys...

Tecnical Details
CPU: intel i5 8600
MOBO: msi b360 gaming plus
GPU: msi nvidia gtx 1070 gaming x
RAM: 16GB (2x8) ballistix sport 2666Mhz
PSU: 650W 80plus gold semi-modular (still looking for its box, i'll update when i'll find it)

Don't really know the previous BIOS version, neither the one i updated to. I could go find it, but i'd need the pc to turn on, because on MSI website many differend bios versions are listed and i didn't pay enough attention to tell which one is the culprit.

I could harvest a spare PSU from another pc i have lying around, but i'd prefer other ideas before trying that... i have to study for upcoming exams and i wasted too much time already trying the aforementioned


p.s. sorry for any mistake, english is not my first language
 

ASK THE COMMUNITY

TRENDING THREADS