Question PC won't turn on with GPU but will without, shows error lights on Mobo for DRAM and CPU

Feb 26, 2021
8
0
10
0
When turning on my PC, it would turn on for a second with error lights on the motherboard for DRAM and CPU then immediately turn off again. The fans would turn on for a second then stop as well. The PC turns on without the GPU with error lights on the same components then disappear after a few seconds.

I tried reinstalling the CPU, cooler, GPU, RAM, and PSU cables. The CPU doesn't have any bent pins and nothing is wrong with the CPU slot. I've also tested the PC with different RAM as well as different GPUs to no avail.

My components are:
CPU: AMD Ryzen 3600 w/ stock cooler
Motherboard: ASRock X570 Steel Legend WiFi ax ATX AM4
GPU: GTX 1070 Ti Founder's Edition
RAM: G.skill Trident Z RBG 16 GB
PSU: EVGA SuperNOVA GA 650 W Gold
 
Feb 26, 2021
13
2
15
0
Not familiar with that mother board but how many slots does it come with for ram . I had that problem before I had 4 slots and 2 8g sticks of RAM and they were in the wrong slots
 
Feb 26, 2021
13
2
15
0
Not familiar with that mother board but how many slots does it come with for ram . I had that problem before I had 4 slots and 2 8g sticks of RAM and they were in the wrong slots
Could also be a bad gpu tho you seen it in action before you got it ?
 
Feb 26, 2021
13
2
15
0
One last thing did you delete all the old drivers and reinstall new ones and the operating system when you switched out the GPU ?
 
Feb 26, 2021
8
0
10
0
One last thing did you delete all the old drivers and reinstall new ones and the operating system when you switched out the GPU ?
The PC has never booted before, I have not been able to get it to boot since I've built the PC. It has no OS yet since I haven't been able to get it to post.
 
Feb 26, 2021
13
2
15
0
Dang I'm assuming this isn't your first build and your 100 percent sure everything is hooked up correctly and plugged in all the way but now Im thinking you got a faulty mother board even when they are brand new parts can come faulty or not function as designed but I really can't help any further without being there to look at it I hope you figure it out soon I know how frustrating it can be when things like this happen .
 
Reactions: Phantamos
Nov 6, 2018
112
5
1,585
0
i experienced this, i manage to do all the troubleshooting but in the end it was a no name V5.0 bluetooth adapter that was plugged on a the motherboards usb slot that was causing a no boot and light errors on ram and gpu. I tried everything stripped down the build and tested each component...on another pc no problems i was just wasting my time lol. Try restarting the cmos battery, and try another motherboard you can borrow if any.
 

Schlachtwolf

Commendable
Jun 22, 2019
665
165
1,640
103
What case do you have, is anything from the mobo touching the case itself, you did use the standoffs to mount the board right? Sounds to me like an electrical issue, shorting somewhere...... can you test with you mates PSU? and test yours in his?
 
Feb 26, 2021
8
0
10
0
What case do you have, is anything from the mobo touching the case itself, you did use the standoffs to mount the board right? Sounds to me like an electrical issue, shorting somewhere...... can you test with you mates PSU? and test yours in his?
Its a Corsair 275R and I used the standoffs provided in the case. I tried reassembling the pc from scratch but I have not tested it with a different psu.
 
Feb 26, 2021
8
0
10
0
Dang I'm assuming this isn't your first build and your 100 percent sure everything is hooked up correctly and plugged in all the way but now Im thinking you got a faulty mother board even when they are brand new parts can come faulty or not function as designed but I really can't help any further without being there to look at it I hope you figure it out soon I know how frustrating it can be when things like this happen .
Actually it is my first build I used pcpartpicker and it didn't say there were any incompatibilities though I did assume there was a faulty part. I returned and got new RAM as well as a replacement gpu so a faulty motherboard is what I'm assuming next. Just going through parts 1 by 1 now.
 

Schlachtwolf

Commendable
Jun 22, 2019
665
165
1,640
103
The most likely point of DOA is going to be the PSU..... Evga have some pretty poor PSU models even if their newer offerings seem to be better. Go for a Seasonic Corsair, beQuiet, I have never had an issue with any of their PSU's.
 
Feb 26, 2021
8
0
10
0
The most likely point of DOA is going to be the PSU..... Evga have some pretty poor PSU models even if their newer offerings seem to be better. Go for a Seasonic Corsair, beQuiet, I have never had an issue with any of their PSU's.
The pc was able to run without the gpu though. There was no post since there was no gpu but the rest of the components ran (case fans, cpu cooler, psu fan). Can the psu be doa but still power some of the components?
 

Schlachtwolf

Commendable
Jun 22, 2019
665
165
1,640
103
Yes, just because the fans are running on the 5volt rail does not mean the 12volt which powers the CPU and GPU is not faulty. If anything it would lead me to believe that the PSU is at fault here, when under more load nothing works....
 
Feb 26, 2021
8
0
10
0
Yes, just because the fans are running on the 5volt rail does not mean the 12volt which powers the CPU and GPU is not faulty. If anything it would lead me to believe that the PSU is at fault here, when under more load nothing works....
Ok I'll try it with a different PSU and see how it works.
 

ASK THE COMMUNITY

TRENDING THREADS