Question PC Won't Turn on?

ShameMate

Reputable
Apr 29, 2017
43
0
4,530
0
Please keep it to 1 thread
Specs:
Intel I7 10700k
Asus TUF Gaming Z490 Plus Wifi
Corsair 4000D

The Motherboard has power, as i can see the LED's glowing when plugged in. However, for some reason the Case button won't work? I have plugged all of the Front Panbel cables in, as you can see here: View: https://imgur.com/a/QHQO896


You can double check to make sure i have them plugged in correctly, but i did follow the manual. I just have no idea why the front panel isn't working :/

Any help would be really appreciated!
 

ShameMate

Reputable
Apr 29, 2017
43
0
4,530
0
Specs:
Intel I7 10700k
Asus TUF Gaming Z490 Plus Wifi
Corsair 4000D

The Motherboard has power, as i can see the LED's glowing when plugged in. However, for some reason the Case button won't work? I have plugged all of the Front Panbel cables in, as you can see here: View: https://imgur.com/a/QHQO896


You can double check to make sure i have them plugged in correctly, but i did follow the manual. I just have no idea why the front panel isn't working :/

Any help would be really appreciated!
 

ShameMate

Reputable
Apr 29, 2017
43
0
4,530
0
Specs:
Intel I7 10700k
Asus tuf gaming z490-plus
Corsair 4000D Motherboard

I have got everything plugged in, meaning:
CPU Power Cables
24 Pin Power Cable
The Front Panel connectors
Harddrives & Fans

For some reason the Motherboard is showing it's getting power by the LED's, but whenever i try to turn the PC itself on, it just doesn't want to boot up? It's like i'm pressing an empty button.

Have plugged in the case into my old motherboard which has a power boot button on it, but that motherboard doesn't want to boot either now so no idea..

Here is a pic of everything plugged in: View: https://imgur.com/a/QHQO896


Would really appreciate it if anyone could help, as this is driving me insane D:
 

Zerk2012

Titan
Ambassador
Specs:
Intel I7 10700k
Asus tuf gaming z490-plus
Corsair 4000D Motherboard

I have got everything plugged in, meaning:
CPU Power Cables
24 Pin Power Cable
The Front Panel connectors
Harddrives & Fans

For some reason the Motherboard is showing it's getting power by the LED's, but whenever i try to turn the PC itself on, it just doesn't want to boot up? It's like i'm pressing an empty button.

Have plugged in the case into my old motherboard which has a power boot button on it, but that motherboard doesn't want to boot either now so no idea..

Here is a pic of everything plugged in: View: https://imgur.com/a/QHQO896


Would really appreciate it if anyone could help, as this is driving me insane D:
I don't see any memory in the slots.
 

ShameMate

Reputable
Apr 29, 2017
43
0
4,530
0
I don't see any memory in the slots.
Would that be a reason for the PC to not boot up? I thought it would at least boot up to a error screen / no memory inserted screen?

Would have also thought the fans would start spinning, i'm tryign to run a boot test to see if it all works first, as ram is coming tomorrow
 

Zerk2012

Titan
Ambassador
Would that be a reason for the PC to not boot up? I thought it would at least boot up to a error screen / no memory inserted screen?

Would have also thought the fans would start spinning, i'm tryign to run a boot test to see if it all works first, as ram is coming tomorrow
Some boards are funny like that wait till you get the memory.
but you would think a fan would run for a second or so.

Edit thinking about it, should be coming on at least.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS