Question PC would randomly restart during WoW, now won't turn on

Aug 13, 2020
1
0
10
0
Hey guys,

So 2 days ago my PC instantly restarted while playing WoW. All fans and motherboard lights turned off instantly, not turning back on for 10 minutes, then managed to boot up. No BSOD.

Freaked me out, right after I took the precaution to buy a UPS for my PC and monitors to assure it's not a bad circuit.

Worked fine until the next day, randomly restarted while playing WoW. My monitors did not lose power and I was able to turn my pc on right after.

Upset at this I did a disk check, made sure BIOS was updated and at optimized settings, updated my drivers and Windows 10. My PC once again restarts while playing WoW after these changes. I turned down all the graphics settings in-game to low and my GPU would be around 60-65 degrees max in-game, CPU wasn't stressed either.

Fast forward to today, I'm using my computer all day for work until the evening. I play WoW for 2 hours until my PC randomly restarts. So at this point I figure it's best to just reinstall a fresh copy of Windows 10 and wanted to have a fresh start hopefully that could work, right?

Well I didn't get much further. I reinstalled windows (backed up my important files), updated it and restarted. While I was in the middle of downloading the drivers, my PC decided to crash AGAIN. I look and see every component inside my PC stops working immediately, but my PSU was still powering the lights on my keyboard, mouse, and microphone just fine via usb. This time I try to push the power button to finish the drivers and.... Nothing.

Even after waiting it seems when I plug my PSU cable into my PSU, nothing inside my pc turns on. No beeps, nothing. Just a dead PC with a keyboard, mouse, and microphone still showing light up RGB colors.

I've come to the conclusion that my last test is testing a new PSU so I ordered a Corsair RM 750W which should arrive in a week. If that doesn't work I can assume my old PSU fried my motherboard and I'll probably be looking into buying a pre-built.

I built this PC back in February so it's heartbreaking to see it go after only 6 months, I'll update once I get the new PSU. Let me know what you guys think about this course of action I decided to take.

Specs:

CPU: AMD Ryzen 2600 3.4 GHz 6-Core Processor

MoBo: Gigabyte B450M DS3h Micro ATX AM4 Motherboard

Ram: OLOy 16gb (2 x 8 GB) DDR4-3000 CL16 Memory

Storage: Samsung 970 M.2

PSU: Corsair TXM Gold 550 Semi-modular ATX Power Supply



(EDIT: So after a few hours my PC started up again, automatic repair was prompted and the only choice is to reinstall Windows again. I plan to not use my desktop for the time being and will test the PSU with a paperclip tomorrow morning.)
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS