Question 'PCI Express Root Port' preventing PC from sleeping?

May 5, 2020
1
0
10
0
So a earlier today, I tried to put my PC to sleep, but everytime I tried, it would wake back up instantly. I thought it was a one off and shut my PC down for that session. After booting it back up a few hours ago and using it, I have now just tried to put it to sleep and it has done the exact same thing. I set it to sleep, the CPU and case fans stop moving, the LED component lights go off, then less than a second later it comes back on again.

Since this problem began earlier today, all I have done on my PC was watch Twitch. I cannot think of anything that I myself have done differently/changed to cause this to happen.

It is really frustrating and means I can only shut down my PC, which I rarely do, mostly I put it to sleep when not using it (which is pretty much only when I sleep). I had a poke around online and found this thread, saying to enter the Event Viewer to see what device is causing the wake-up, which worked, I now know. However nobody in the thread has the same Wake Source as me; mine is 'Device -PCI Express Root Port'.

Exactly from the Event Viewer it says:
  • The system has returned from a low power state.
  • Sleep Time: ‎2020‎-‎05‎-‎04T22:56:03.584270300Z
  • Wake Time: ‎2020‎-‎05‎-‎04T22:56:17.014399700Z
  • Wake Source: Device -PCI Express Root Port
This of course happened a few times, but this is the most recent. You can see there how quickly it is waking up again.

Since nobody on the thread had the same Wake Source, there are no fixes there.
Does anyone know what could be causing this to wake using info from the Event Viewer, or do I need more? My PC is running Windows 10 Home version 1903.
 

Colif

Win 10 Master
Moderator
Try a clean boot and see if it changes anything - make sure to read instructions and make sure NOT to disable any microsoft services or windows won't load right - https://support.microsoft.com/en-au/help/929135/how-to-perform-a-clean-boot-in-windows

if clean boot fixes it, it shows its likely a startup program. You should, over a number of startups. restart the programs you stopped to isolate the one that is to blame.

the devices that run off that root are mice, ethernet and possibly gpu. Could look at them in device manager and see if any set to wake on sleep... its possible you got a driver update today via windows store.
 

ASK THE COMMUNITY

TRENDING THREADS