namek0

Distinguished
Oct 21, 2002
589
0
18,980
I know this isn't a cpu question, but my question is so obscure I want to have many many eyes on it to see if they can help me out.

Up until a month ago I had no problem, so here we go: I got tired of having to use the back ports of my old computer to use my usb flash drive, so I bought a cheapy pci usb card that went in the 5/14 bay. It came with an ultra generic "driver cd-rom" cd. For 6+ months it worked perfectly and never gave me any fits.

Last month, all of a sudden my lexar 256m flash drive stopped working on my front ports (pci card ports) My only option was to either use my onboard mobo ports (in back) or to use the usb1 ports on the front of the case. The device works fine everywhere in the known universe except in my computer.

At first I figured it was a driver issue, so I tried to find where they were in the device manager. I couldn't find it specifically, so I just uninstalled all of the usb devices/controllers and reinstalled them. This didn't fix anything. Although, I was never prompted for a driver location because the drivers installed themselves automatically (most of which were my mobo usb ports/controllers and a little bit of usb printer stuff)

Are there some sort of temp driver files where they're all stored and if so can it be wiped? I have a feeling if I reinstalled it totally fresh (where I would normally be prompted to give it driver directions) that it would start working again. It's the wildest thing, because everything works in it except for my flash drive. My older 64meg ge usb1 drive works fine in the pci-usb card.

I'm stumped and sitting here working the night shift at the computer lab ane thought I'd throw out my problem on the forum. If you have any suggestions I'd love to here them. I got spoiled and I'm damn tired of waiting for the usb1 speed when transferring stuff, thx guys

It's all good ^_^
 

P4Man

Distinguished
Feb 6, 2004
2,305
0
19,780
Can you try another USB2 device on the PCI card ports ? USB2 signalling is quite a bit more stringent than USB1, you could well have a hardware problem. Or maybe its something as silly as the cables not making proper contact, try reseating them.

As for removing the devices in device manager, indeed, it will just "rediscover" them, and use the old drivers. instead, uninstall the devices from the device manager, reinstall the drivers, reboot. But unless you changed something else to your config, I doubt its a driver issue really.

= The views stated herein are my personal views, and not necessarily the views of my wife. =