Question PCIe card worse signal than USB phone hotspot

TBe

Oct 8, 2020
2
0
10
0
Hi guys,

Recently, I bought a TP-Link AC1300 Wifi PCI Express-adapter (Archer T6E) since I can no longer connect my PC with an ethernet cable. The router is in a miserable spot two floors down, so the signal is expected to be a lot weaker. I am connected to a 5GHz connection and, using the command prompt, the signal strength varies between roughly 8 and 12%.

However, when I create a USB hotspot through my phone, the signal is a lot stronger and I get a much better connection, even though my phone is roughly placed on the same location. So the location of my PC and wifi adapter is probably not the only problem that contributes to the slow speed. I made sure I have the latest drivers installed for the PCIe Wifi adapter. My phone is connected through a 2.4GHz band, which, I expect, to perform better further away from a router with more walls and floors to block the signal. I cannot find a way to force my adapter to connect to the 2.4GHz band through device manager (though I might be looking at it the wrong way).

Any suggestions how I might solve this problem? Or how to force the adapter to connect to the 2.4GHz band? Any help is appreciated!
 

Phillip Corcoran

Titan
Moderator
Device Manager is not where you need to be for this task.

In the list of available wireless networks on your PC, you should see two entries for your router's SSID --- one for 2.4 GHz and one for 5 GHz.
Just connect to whichever one you want to use (provide WiFi key/password when prompted if this is a new or previously unsaved connection).
 
Sep 12, 2020
62
17
45
1
I cannot find a way to force my adapter to connect to the 2.4GHz band through device manager (though I might be looking at it the wrong way).
If Phillip's suggestion doesn't help (because both bands have the same SSID), then head back to Device Manager, double-click on the wireless adapter -> "Advanced" tab. Look through the properties for something called "Band" or "Preferred Band" and set it to 2.4GHz. Note that not all wireless cards have that option so you may be unlucky.
 

TBe

Oct 8, 2020
2
0
10
0
Thanks for your replies!

In the list of available wireless networks on your PC, you should see two entries for your router's SSID --- one for 2.4 GHz and one for 5 GHz.
There was only one network showing up at first, but I disabled the function called Mesh that automatically connects to the best signal. Both the 2.4GHz and 5GHz (which I renamed) SSIDs are showing up, although, after inputting the password, I'm getting a message that it is not possible to connect to this network (the 5GHz one is working fine, albeit with the same slow signal). The adapter should be able to connect to both frequencies as advertised by TP-Link.

If Phillip's suggestion doesn't help (because both bands have the same SSID), then head back to Device Manager, double-click on the wireless adapter -> "Advanced" tab. Look through the properties for something called "Band" or "Preferred Band" and set it to 2.4GHz. Note that not all wireless cards have that option so you may be unlucky.
I'm sorry if this a stupid question, but 'the preferred band' setting allow for three options: 'none', '802.11a' and '802.11g/b'. Which one should be used?
 
Sep 12, 2020
62
17
45
1
but 'the preferred band' setting allow for three options: 'none', '802.11a' and '802.11g/b'. Which one should be used?
802.11g/b/n should tell the adapter to only connect to 2.4GHz networks. However, you're now telling us that you're unable to connect to your router's 2.4GHz band so my tip is unlikely to help.

Simply turning your router off for a minute or two may help fix this. If it doesn't then make sure your PC has the latest wireless adapter drivers from the TP-Link website.
 

ASK THE COMMUNITY