Question PCIe x1 slot on top doesn't work, other works fine

Apr 2, 2020
2
0
10
0
Motherboard picture: View: https://imgur.com/1mJrjWO


I have Asus P8P67 Deluxe and Intel 2600k, and it has a total of 5 PCIe slots. 1 slot is a 16x or 8x (blue, second from CPU in picture), second PCIe slot is 8x only (white) and is shared with the first one, mainly for 2 video cards setup. Then there's two x1 (both blue) and x4 (black slot, x4 is a x16 slot physically but only runs at x1 or x4).

x1 slot does not have any opening on the side so it is strictly limited to x1 card only ( I guess it's intentional to prevent someone from accidentally installing a video card into that x1 slot!). The second x1 slot, being next to x16/x8 slot is blocked with large video card's fan shroud so that one is useless. (there's also a couple legacy PCI slots, light blue, those aren't used at all)

Currently I have two RX 480 in x16/x8 and in x8 slot, and M.2 SSD card in x4 slot (requires x4 or larger slot, will not fit x1). I wanted to add a SATA card which is x1 but when I have it in the top x1 slot, computer does not detect it. If I move it to the x8 slot or x4 slot, it is detected and working fine. However this means I have to remove my second video card or my SSD card.

I looked in the manual and I can't find anything to explain why the x1 slot doesn't work at all.

I really don't want to replace the whole motherboard, so any idea why x1 slot won't work? The alternative is to pay about $100 for P8P67 Revolution which has more PCIe slots (and no legacy PCI slots) but if I'm going to spend a lot, I might as well get something that is made this year with built in M.2 slot and at least 12 SATA 6G ports, and not something released 6 or 7 years ago.
 

ASK THE COMMUNITY

TRENDING THREADS