Question pcie16 power connetced to peripheral-floppy - SPARKS! pls help

Jul 13, 2019
2
0
10
0
neighbor tried to upgrade video card, plugged his pcie16 power supply into the modular psu output for peripheral / floppy
said sparks resulted and now system wont boot.
power on results in POWER LED briefly lighting on asus mobo, then fading
what are the odds he damaged everything?
think he fried the mobo ,and GPU? (new 1050ti)
tried to help, only able to verify PSU still works (brought over and old pc and fired up that one with his power supply)

any thoughts appreciated
 
Each component will need to be tested individually...

Should not take long, given a good system to experiment with....

If the PSU's intended GPU output was connected to a wrong device/differing pinout, I'd have expected the PSU to have been shorted...

(You said it won't 'boot', but, per chance do you mean the rig now gives no display in BIOS as well? )

Does the MB and CPU in question support integrated video out of mainboard? And if so, does that function?
 
Jul 13, 2019
2
0
10
0
Each component will need to be tested individually...

Should not take long, given a good system to experiment with....

If the PSU's intended GPU output was connected to a wrong device/differing pinout, I'd have expected the PSU to have been shorted...

(You said it won't 'boot', but, per chance do you mean the rig now gives no display in BIOS as well? )

Does the MB and CPU in question support integrated video out of mainboard? And if so, does that function?
yes, it wont even that far. a green led on motherboard powers and fades
the led label is "power"
board does have onboard video
 

ASK THE COMMUNITY