Question Peripherals not recognized after bios update and overclock failure

Dimitri3p0

Honorable
Sep 18, 2014
3
0
10,510
0
Hi all,
First let me apologize if this answer is elsewhere, I've looked a bit and found lots of similar threads but nothing that has helped me solve my issue. But pardon my ignorance if the answer is out there.
I recently decided to upgrade mypentium G3258 to a used I7 4790. Mobo is MSI z97 u3 plus.
When my new CPU arrived directions recommended that I update bios before swapping. Downloaded appropriate bios update from MSI, used a usb stick to M-flash bios. This was successful, however upon restart I got a message indicating my overclock had failed (old cpu was still in place g3258, which had been overclocked to 4.0 Ghz). I thought I selected an option to take me back to bios to sort it out, however, comp restarted, and then monitor wasn't receiving signal, nor mouse or keyboard it seems. I've tried clearing CMOS and jumping cmos ram to no avail, also have followed this: https://forum-en.msi.com/index.php?topic=269702.0 . whenever I start up I can't see or interact with anything, can't get to bios etc. but fans and LEDs seem to run normally. I've also tried having monitor plugged directly into mobo instead of GPU, as well as trying with less/more ram sticks.
Does this mean my mobo is spent? Did I fry my CPU? Or is there another way to reset it back to defaults? i should've done my research before updating bios obviously, but here I am.
I will greatly appreciate any suggestions, thank you.
 

ASK THE COMMUNITY

TRENDING THREADS