Pfn_list_corrupt on a home build. Any advice?


Sep 30, 2011
Hi all,

I've been working on a build for a friend over the past month, and I'm nearing the end of my rope. I've even taken the system to a decent shop for advice without success.

The system will post with no error messages, but when I try to install windows it gets to the end of loading the drivers and BSODs with the following error message:


Clocking down the memory and/or shutting off some nonessential MB elements yields a new error message, but same result:


I've searched the forums and tried what few suggestions I could find with no luck.

Here are the specs for build:

CPU -- Intel i5 - 2400
Cooler -- Thermaltake CLP0564 FRIO
MB -- ASUS P8P67 PRO (1155 Sandy Bridge chipset)
Memory -- Corsair Dominator 2100 DDR3 4GB (CMT4GX3M2A1866C9)
Power Supply -- CORSAIR Gaming Series GS800 800W
Graphics Card -- MSI N560GTX-Ti Hawk
Hard Drive -- Western Digital Caviar Black WD1002FAEX
DVD Drive: -- LITE-ON Blu-ray Reader Model iHOS104-06
Windows 7 Premium 64-bit OEM (full install)
Case: Thermaltake VH6000BWS

And here's what we've tried so far.

-Updated to latest BIOS
-Swapping motherboard for an identical model. (per the suggestion of said local shop)
-Swapping out Blu Ray Drive for a standard CD drive
-Swapping out Win 7 CD for a known good install CD.
-Swapping out memory for DDR3 1333 on ASUS QVL components list
-Swapping out graphics card with known good card.
-Swapping out hard drive for another SATA drive with fully functioning copy of Win7 from another computer)
-Swapping out power supply (for another model also not on QVL)
Unplugging all nonessential motherboard components and shutting off all nonessential components in BIOS (Marvell ports, Audio, LAN, USB, etc)
-clocking the RAM down to 1066
-various BIOS configurations.

As you can see, we've replaced everything but the CPU. At this point I'm thinking it's some kind of configuration problem I just can't nail down. I'm thinking about swapping the MB for a Gigabyte GA-P67A-UD4-B3 but at this point I'm really just shooting in the dark. My friend has sunk a sizeable chunk of change into this system, and it's starting to look like I'll have to as well to get it up and running. Is there anything I might have missed? Any suggestions would be appreciated.
Well , if you have replaced everything but the cpu , what does that tell you. Do you have another good known cpu that you can use to test. Also if you have recently purchased it then I would think you should be able to call Intel tech support and see if the error message you are getting has anything to do with the cpu.


Sep 30, 2011
Everything I've researched on this error has come up with

1) Memory
2) Motherboard
3) Power supply (this is a longshot)

Nothing that I've seen so far suggests CPU, and I'm hesitant to drop a chunk of change to get a replacement.
We've been working on this build so long that most of the parts are outside the RMA window. :(
I'm considering dropping the CPU off at the shop and paying them to test it for me.

Would the fact that I can't even get Memtest to run suggest the CPU is a possibility?


Apr 7, 2011
Have you tried putting the Windows 7 CD onto a USB drive? There are guides out there that tell you how to make a USB drive bootable and then you just copy the contents of the W7 disk onto it. It's another thing to try.

You've replaced everything but the CPU, and the configuration is fine, so it may very well be the CPU that's not working. If you can RMA it, I would do so. If not, try Intel's guarantee process, it should be good for 5 years I think.