Question PFsense Web Configurator loads into blank https and http webpage. Why is this happening and how can I fix it? Please help

Oct 31, 2021
1
0
10
0
Hi!
So obviously from the title, I need some help with my pfsense install.
Currently, I have the pfsense-CE-memstick-serial-2.5.2-RELEASE-amd64.img installed onto my Protectli router/firewall. It boots into the menu no problem.
Things I have tried:
  • booting using BIOS and UEFI
  • using different ISO files
  • using different file storage/partition types (zfs, ufs, manual drive config, auto drive config)
  • specifying port 80 or 443
  • following tutorials
  • restarting web config using option 11 through the menu
A little more on what the webpage loads to:
The webpage loads to a blank white screen with no source code other than the basic html tags.
Ive also installed the same version on a VM and it seems to have worked, as I was able to configure the configurator.
------------------------------------------------------------------
Unfortunately, none of these worked, so now im stuck. If anyone has any suggestions, I'd love to hear them. Thank you
------------------------------------------------------------------
P.S. Not sure if it matters, but I'm connected to the console port using rs232-usb and the provided rj45-db9
 

ASK THE COMMUNITY