Planetside 2 frame rate issues

Tahoe51

Honorable
Dec 20, 2012
1
0
10,510
Hi, I could really use some advice on what exactly I am doing wrong when it comes to Planetside 2. The issue I’m having is that no matter what I cannot get my framerate to jump above 30 FPS in most situations, and in any sort of intense combat with a large number of other players around it drops down to 15 FPS or lower. On top of that I frequently get random (and extremely severe) framerate drops for what seems to be no good reason, and there have been several occasions when I've gone down to 1 FPS for several seconds when nothing graphically intensive is around me at all. What's weird to me is that it doesn't seem to make any difference what settings I have the game on--from bare minimum with 1024x768 to max settings for everything with 1920x1080--I cannot improve or drop my average FPS at all. I'm able to play other games like Borderlands 2, Dark Souls, Stalker: Call of Pripyat, and Metro 2033 with maxed settings at 60+ FPS flawlessly, and from what I’m able to understand of the minimum/recommended requirements for Planetside, I meet all of the minimum and almost all of the recommended. Any advice on what to do would be greatly appreciated.

My specs (I’m no computer expert, so tell me if there are things you need to know I’m leaving out)

OS: Windows 7 64bit home premium

Processor: AMD Athlon II X4 640

RAM: 4GB

Motherboard: msi 785GM-E65

Graphics card: GeForce GTX550Ti

694 of 931 GB free on my hard drive

And, just in case it’s important, I have a 1.5mbps internet package from Century link. I know it’s extremely slow, but I've never had framerate issues online with any other game I've played on my PC or ps3.
 

Serthy

Honorable
Dec 11, 2012
62
0
10,640
It could just be the fact that planetside might have been designed at 30fps because of all the action going on?

I'm probably wrong but your system seems to be good to me, So i wouldn't freak out as much.

Could try running it in windowed mode if that is supported, or try doing the normal system maintenance to see if that clears it up.