[SOLVED] Playing videos on my main monitor have a green and purple tint.

chumpy_

Prominent
Dec 30, 2020
13
0
510
0
As stated in the title when i play any videos on my main monitor they have a green and purple tint, this includes youtube, video game clips, twitch and basically any other playing videos. This effect does not persist on my second monitor though. I believe it may have something to with video codecs or something but i am not educated on what i can do to fix this. It only happens to playing videos and not anything else. These images are taken on my main monitor (one with the green and purple tint) and my second monitor which looks normal. Any help is appreciated.
 

little_me

Distinguished
If issue is not monitor itself, similar issue was here and it was due to default settings being off in nvidia control panel.
https://forums.tomshardware.com/threads/why-do-all-my-videos-keep-going-green-not-just-youtube.3737790/post-22549306

DDU would kind of fix this since it wipes all changed default settings and thus reinstalling they'd be at default but... if it's due to this... there is no need to go that far for solution.
Bear in mind though, this would affect ONLY videos/games, not desktop items or desktop itself.

Not sure what GPU you have but I'm quite certain AMD has something similar too.
 
As stated in the title when i play any videos on my main monitor they have a green and purple tint, this includes youtube, video game clips, twitch and basically any other playing videos. This effect does not persist on my second monitor though. I believe it may have something to with video codecs or something but i am not educated on what i can do to fix this. It only happens to playing videos and not anything else. These images are taken on my main monitor (one with the green and purple tint) and my second monitor which looks normal. Any help is appreciated.
How are the monitors connected with the GPU? Have you tried another cable to the problematic monitor? If you are using an adapter you might need to consider changing it or buying a proper cable for it.
 

little_me

Distinguished
If issue is not monitor itself, similar issue was here and it was due to default settings being off in nvidia control panel.
https://forums.tomshardware.com/threads/why-do-all-my-videos-keep-going-green-not-just-youtube.3737790/post-22549306

DDU would kind of fix this since it wipes all changed default settings and thus reinstalling they'd be at default but... if it's due to this... there is no need to go that far for solution.
Bear in mind though, this would affect ONLY videos/games, not desktop items or desktop itself.

Not sure what GPU you have but I'm quite certain AMD has something similar too.
 

chumpy_

Prominent
Dec 30, 2020
13
0
510
0
If issue is not monitor itself, similar issue was here and it was due to default settings being off in nvidia control panel.
https://forums.tomshardware.com/threads/why-do-all-my-videos-keep-going-green-not-just-youtube.3737790/post-22549306

DDU would kind of fix this since it wipes all changed default settings and thus reinstalling they'd be at default but... if it's due to this... there is no need to go that far for solution.
Bear in mind though, this would affect ONLY videos/games, not desktop items or desktop itself.

Not sure what GPU you have but I'm quite certain AMD has something similar too.
yeah its only videos and not games though. multiple games like COD MW and others that support nvidia stuff dont have the issue. Only videos that are actively being played on my main monitor. When i start a vid on my second monitor and pause it then, drag it over to my main monitor it stays at normal colors until i click play.
 

chumpy_

Prominent
Dec 30, 2020
13
0
510
0
How are the monitors connected with the GPU? Have you tried another cable to the problematic monitor? If you are using an adapter you might need to consider changing it or buying a proper cable for it.
It isnt the cable sadly and i do not use any adapters, it is hmdi to hdmi
 

chumpy_

Prominent
Dec 30, 2020
13
0
510
0
If issue is not monitor itself, similar issue was here and it was due to default settings being off in nvidia control panel.
https://forums.tomshardware.com/threads/why-do-all-my-videos-keep-going-green-not-just-youtube.3737790/post-22549306

DDU would kind of fix this since it wipes all changed default settings and thus reinstalling they'd be at default but... if it's due to this... there is no need to go that far for solution.
Bear in mind though, this would affect ONLY videos/games, not desktop items or desktop itself.

Not sure what GPU you have but I'm quite certain AMD has something similar too.
Also i have a 1080ti Duke edition and my nvidia video color settings are default.
 

ASK THE COMMUNITY