Question please confirm i'm hosed

Jul 19, 2019
3
0
10
0
I think my old rebranded clevo laptop is beyond home repair and i'd appreciate a best-bet confirmation of that from anyone who knows more than i do. It has other problems and i only use it as a media downloader and player, so it's not worth spending any money on it.

It was working fine with no warnings about what happened next. I ran it off a live usb to resize the partitions, and the bios menu seemed to be having trouble saving the new boot order. After i was done and tried to reboot, i get what looks like the first ~1 second of boot, including power lights, a nudge to the dvd drive, and a spin of the fan (which stopped after a few tries). Then nothing, blank screen. No indicator lights on preinserted thumbdrives, which is supposed to happen very early in the boot process. No response to boot menu button (standard one plus various others suggested online). No help from removing the motherboard battery for a long time. No error beep from trying to boot without ram (not sure about this motherboard but i gather that's a common indicator). No help from swapping ram sticks, or any combination of battery in/out, hd in/out, most anything i could try disconnecting. The 1 second of boot is the same under all conditions.

Seems to me like something is broken at a boot stage too early for an end-user to fix, my guess being corrupted bios or hardware fail of memory holding it, etc.

In any case, of course you can't tell for sure, but i'd appreciate an experienced person's confirmation that i'm probably hosed.

Thanks for the forum, and thanks in advance for reading and any response,
Hosey McHoseface
 

ASK THE COMMUNITY

TRENDING THREADS