Please help.. Built my PC and it does not work

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680
I finally finished building my PC, plugged the PSU in turned it on and... nothing turned on at all. I kept turning off and on the PSU to see if it would power up and after doing it for about a minute the one case fan's LED lit up for a split second then turned off.. I dont know what to do. Also the PSU fan does not spin could that mean that the PSU arrived dead? Also, I've read the troubleshooting sticky and nothing seemed to help.

Here's what I have
PCPartPicker part list / Price breakdown by merchant / Benchmarks

CPU: AMD Phenom II X4 965 Black 3.4GHz Quad-Core Processor ($89.99 @ Amazon)
CPU Cooler: Cooler Master Hyper 212 EVO 82.9 CFM Sleeve Bearing CPU Cooler ($29.99 @ NCIX US)
Motherboard: ASRock 970 Extreme3 ATX AM3+ Motherboard ($84.99 @ Newegg)
Memory: G.Skill Ripjaws Series 8GB (2 x 4GB) DDR3-1600 Memory ($38.98 @ Outlet PC)
Storage: Seagate Barracuda 1TB 3.5" 7200RPM Internal Hard Drive ($67.99 @ NCIX US)
Video Card: MSI Radeon HD 7770 GHz Edition 1GB Video Card ($112.55 @ Newegg)
Case: Zalman Z9 Plus ATX Mid Tower Case ($51.00 @ Newegg)
Power Supply: Corsair Builder 430W 80 PLUS Certified ATX12V Power Supply ($24.99 @ Newegg)
Total: $500.48
(Prices include shipping, taxes, and discounts when available.)
(Generated by PCPartPicker 2012-12-09 23:29 EST-0500)

Please tell me anything that could be wrong, or other ways I could troubleshoot. Also, while building the pc I had an anti-static wristband on the whole time,
 
Solution
if you took the front off, did you reconnect the case power lines, your case should have a set of multiple 2 wire connectors usually labeled pw or power sw reset sw hdd led power led and so on (usually something similar at least) if those are not connected (the power SW) specifically your computer wont be able to turn on

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680
When I plug the 24 pin thing in, it is a little loose and will not snap on.. Also, when looking at it seems like it is missing something heres a picture

3022joj.png
 

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680


No, would I actually have to take the psu out of the case? Or can I just leave it in there but unplug everything?
 

Theb_Sol

Honorable
Dec 10, 2012
17
0
10,520
an old mistake i made the first time i built a pc was in forgetting to place the motherboard spacers/ improperly placing too many, causes a similar situation, pc will not power on, i dont know your level of expertise but i would check this first as sometimes the simplest thing can be the whole problem
 

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680



This is my very first build thats why I am worried, but if you're talking about the stand offs, I made sure I used the correct amount and placed them all in the right place
 

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680


Would I have to take out the mobo and everything else if I remove the psu
 

Theb_Sol

Honorable
Dec 10, 2012
17
0
10,520


yes im referring to the standoffs, another item on my checklist.. it to verify you turned the PSU on... sounds ridiculous but when ive trained students to build new pc's it happens more oft then not. im not trying to rule out a bad psu or other component but rather give you items that i would verify before attempting to send the psu off for repair.

check the ram, did you install it in the slots starting with 0, not 2 and 3, did you move any jumpers on the motherboard, if so, check which ones ensure it was not the cmos jumper this will depending on motherboard prevent a boot, double check your power button on your Case is working.

make sure the power switch is hooked to the proper motherboard jumper...
i could go on and i have a few other steps i would try but, they are a bit more risky in terms of doing it wrong could fry hardware.

^and no you wont have to take the motherboard out to remove your PSU (unless it physically will not fit) without removing the motherboard or other hardware
 

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680
Ok, did the psu test the case fan and the psu both turned on. Thanks for all your help so far. I'm going to put the psu back in the case. Also I don't think I removed any jumpers.. I dont even know what they are
 

Theb_Sol

Honorable
Dec 10, 2012
17
0
10,520
im glad the psu came on, at the same time that could afford thinking its your motherboard or CPU / RAM id first remove one stick of the ram installed and see if it will boot, if not attempt to boot with the other ram stick, remember to use the port labeled 0 in your manual.
 

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680



Well I have an aftermarket cooler on and I wont be able to take out the first ram stick since theres almost no room.. Could this be a problem in the future?

Also would I be able to hook up the 24 pin to my mobo and connect it to my case fan to see if my mobo works? or could that cause problems
 

Theb_Sol

Honorable
Dec 10, 2012
17
0
10,520
yes, you have to have the 24 pin, and sometimes a 4 pin supplemental cable connected to power on the computer , your hard drives/ graphics card (gpu) and any other "cards" inserted into the motherboard should be temporarily unplugged until you've tested the motherboard.

bleh hate when i forget something in a post, check the first ram stick to make sure it is vertical not slanted to one side. if your fan is too large it could be causing your ram to disconnect by pushing it away from the contacts,
 

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680



I just watched a tutorial on how to instal ram, and when watching it I seen the clips on the side of the RAM lock automatically, when I added ram I just gently put it in there and locked it in place and it would pop out easily.. so now I just put the ram in and it did the same as in the video and now it won;t wiggle as before. Could this have been the problem of it not starting the system at all? I'm going to plug in the power cables back in the correct spots and give it a go.
 
Yeah, it sounds like you haven't installed the RAM properly.

The RAM goes into the slot and the clips on both side should snap in.

Also, the power to mobo should also be firm (clip to place).

Make sure you connect things in firmly and clip to place!!!! :lol:
 

Theb_Sol

Honorable
Dec 10, 2012
17
0
10,520
most parts should "snap" or fit snugly, sorry for the delay to my replay had a fun BSOD

you were wise to not force things into place but it does require a firm hand as Pyree stated

if possible place a finger or two under the area where the 24 pin connects to help keep it steady so it will fit in place properly
 

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680



Yeah sure, also a quick note I had to take off the front of the case to put in my optical drive could it be a possibility that I didn't put the case on right so the power doesnt work?
 

Theb_Sol

Honorable
Dec 10, 2012
17
0
10,520
if you took the front off, did you reconnect the case power lines, your case should have a set of multiple 2 wire connectors usually labeled pw or power sw reset sw hdd led power led and so on (usually something similar at least) if those are not connected (the power SW) specifically your computer wont be able to turn on
 
Solution

sesbetr72

Distinguished
Nov 22, 2012
99
0
18,680


Wow.. I feel like an idiot. I did not even notice the front even had wires I needed to connect, sure enough when I did the system turned on. THANK YOU SO MUCH I thought I wasted my time/and money I will message you if I have any further questions.