Please help! Can't enter BIOS!!!


Apr 22, 2007
I'm a newbie in computer hardware and this is my first time building a PC. Major problem happened after first start, please help~:(

Firstly, here is my specs:

MoBo: ASUS P5N-E SLi 650i LGA 775 NVIDIA nForce
CPU: C2D E6600
RAM: Corsair TWIN2X2048-6400C4 2GB Kit DDR2-800 XMS2-6400
GPU: eVGA e-Geforce 7600 GT KO PCI express 256MB GDDR3 Video Card
PSU: Antec Neo HE 500W

When I hooked everything up and hit the power, the graphic screen showed up and there was "Set up BIOS press DEL" at the bottom. When clicked "DEL", nothing. Tried several times by holding F1, DEL, TAB, but no response. Not a keyboard problem since I tried both P/S2 and USB, keyboard LED is ON; Cleaned the CMOS, replaced the on board battary, reconnected each wire, even changed with a BFG 800W PSU! Still no progress :mad:

I've lost here. My friend said the ASUS MoBo could be a bad one. Anyone has some suggestion? TIA!!!
I would hook up a speaker directly to the board. If your case doesn't have one, you can buy a cheap one from radio shack and attatch or solder the connecting wires yourself. You need to see if any beep codes are present when posting. You can also try just one stick of memory in each slot to see if you have a memory issue. If all else fails, I would flash the bios. Some asus boards come with a bios recovery program on the cd. I load the bios program on a floppy and use a separate floppy with a bootdisk program. You can create a free bootdisk at


Did you try repeatedly tapping DEL? Sometimes even when it says press DEL, it doesnt register that you pressed it until it has done certain POST tests (usually memory scan). So yea, try repeatedly tapping DEL.