Please help me

hzar89

Distinguished
Dec 11, 2009
26
0
18,530
0
i just bought the gtx275 then went i started to play game after a few minutes it will hang..
when i open the case and i realize that the connector doesn't put properly and when i repair that it doesn't hang anymore for now...
could that be the problem?
but the things that make me curious if it doesn't insert properly why it still can be running for a while????
does my hardware have a problem?
 

skolpo

Distinguished
Sep 20, 2009
695
0
19,060
36
You do not have to connect both 6-pin connectors to run the card but it will run very poorly. I'm pretty sure you've fixed your problem by firmly connecting the connectors. Report back if the issue still exists.
 

hzar89

Distinguished
Dec 11, 2009
26
0
18,530
0

does it effect on my pc component?
why it still can be run before even the connector does not properly insert?
 

skolpo

Distinguished
Sep 20, 2009
695
0
19,060
36
No, it will not cause any damage to your graphics card. The only way it will cause damage is if you still run the card with one or none of the PCI-E connectors connected and the computer keeps hanging and you have to reboot by turning off the power.

Graphics cards can run with very little power, but if you want it to run at its advertised speed and performance, you need to give it the required amount of power. The GTX 275 requires 2x 6-pin PCI-E connectors. Connecting only one will cause it to run poorly but it can still run. When it hangs then the video card is demanding more power than you're giving it.
 
The card worked without the connector inserted properly because the amount of power it needs varies depending on any particular moment/task. It gave out when it needed more power than could be supplied without the connector.
 

ASK THE COMMUNITY

TRENDING THREADS