Question PLEASE HELP! Why wont my PC display this graphics card? Fail at POST. MOBO?RAM?HDD?[UPDATED]

Mar 24, 2019
1
0
10
0
I am upgrading from a GTX 960 to an AMD RX570. I uninstalled nvidia using DDU in safe mode. After installing the new hardware and powering on, I get the usual post startup success beep and then 8 beeps that I've read means, "display memory read/write test fail" and the card does not display.
The RGB drivers on my keyboard start up so I think it's safe to assume the system boots windows. I've tried the RX570 on my friends PC and it displays, so something must be faulty in my system.
I've tried resetting the BIOS to default and booting with the new card but that did not work. Could there be other firmware problems? Should I try updating my BIOS?
I tried to do a kind of UEFI boot, but that did not work. Should I try more of that?
I want to try booting with my backup HDD instead of the main, see if that does anything. Does anyone have any information for safely troubleshooting/swapping RAM, I dont think the quantity or quality of my ram is an issue at the moment.
Could it be that there is a compatibility issue with the new gpu and my "chipset" whatever that means?
Please suggest compatibility solutions.

Working Build:
CPU: Intel i7 2600k 3.4ghz
Motherboard: BIOSTAR tp67xe
RAM: 4x 4GB Corsair Vengeance
HDD: Western Digital 2tb
GPU: EVGA 2gb GTX960
PSU: Corsair TX 750
Chassis: Lian Li
OS: Windows 10 64-bit

Trouble component:
GPU: AMD RX570
 
Last edited:

Lutfij

Titan
Moderator
When posting a thread of troubleshooting nature, it's customary to include your full system's specs like so:
CPU:
Motherboard:
Ram:
SSD/HDD:
GPU:
PSU:
Chassis:
OS:

Apart from the make and model of the unit, how old is your PSU?
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS