Please power down and connect the PCIe power cables for this graphics card" GTX 1070

Apr 22, 2018
6
0
10
0
Hey, so I've recently built a PC with some help, however I keep getting the error in the title when booting up. I have an 8pin plugged into the GPU and the other end being 6+2 into the PSU. (PSU is the Corsair CX750M) I've reseated the card many times, and tried many other things and am at a complete loss.
Also, It will boot up when I just plug into the MOBO.
 
Apr 22, 2018
6
0
10
0

I thought the same, but the 8pin will not fit anywhere in the PSU, its slotted and sliders perfect into the card
 
Apr 22, 2018
6
0
10
0

No sorry, can't figure out how from my phone. On the PSU end I have the 6+2 plugged into the top right (labeled 6+2 PCI-E) and the other end being an 8 pin, plugged directly into the EVGA Geforce GTX 1070 SC
 
Apr 22, 2018
6
0
10
0

I don't believe my PSU has a fan, atleast not on top. And the 8 pin will not fit into the PSU, only GPU. Maybe buddy gave me a messed up cord or something...
 
Your buddy gave you a cord? You can ONLY use the exact modular cables that are for that specific make and model of PSU. Don't try and power anything on until you get the right cable. The 6+2 never goes into the PSU.

Edit - if the PSU is mounted on the bottom of case, the fan is facing down and that's OK (there are grills for air there).
 
Apr 22, 2018
6
0
10
0

The fan was facing down, I did a little research though and that doesn't seem to be the wrong way, the bottom of the case is mesh, so no obstruction.
 
Apr 22, 2018
6
0
10
0
I think you're right, fortunately nothing happens when I have been trying to boot, I automatically get that error message, and it goes no further. Time to try and find another cord and wait longer :(

 

ASK THE COMMUNITY

TRENDING THREADS