Question Plugging in a second monitor causes both to go black until one is unplugged

Nov 14, 2020
2
0
10
0
Hey Tom's forum: I come to you after an exhaustive session of debugging the issue described. Normally I'm the guy people come to with these questions, but I'm at a loss. I will describe in more detail now:

I have one AsusVG248 connected direct to video card via DVI. I have another monitor Asus246H that's plugged into the video card using HDMI.

One day, without provocation, the HDMI connected monitor did not turn on after booting. When I went to windows and hit detect monitors, both turned black. The computer does not shut down or crash. From this state, if I unplug the hdmi monitor the DVI one will turn back on.

To make things even more strange, I swapped inputs for both monitors. I plugged the HDMI into the 248 and the DVI into the 246, and they both worked! Then I plugged them back into their original configurations, and the same problem persists!

I'm honestly at a loss. I've swapped out the video card, same problem. I've swapped out the cables, same problem.

Drivers are up to date... Any ideas my friends?
 

Lutfij

Titan
Moderator
Make sure you're on the latest BIOS version for your motherboard. Go to your GPU manufacturer's support site and download the latest drivers for your GPU. Then use DDU to uninstall your GPU drivers. Once done, you should disconnect from the internet and manually install your GPU drivers in an elevated command, i.e Right click installer>Run as Administrator.
 
Nov 14, 2020
2
0
10
0
Hey @Lutfij, thanks for your reply! I followed the instruction exactly as given, and still the problem persists....

Any other ideas?
 

ASK THE COMMUNITY

TRENDING THREADS