Question Poor performance for 5 mins after installing drivers

Sep 2, 2020
3
0
10
0
I have a rx590 and every time in install new drivers I get massive stuttering and frame drops. I’ll mess around a lil bit until the frame spikes even out a little then restart the game and everything is smooth as butter until the next time I switch drivers. I’ve rma’d it twice. The first time they said they could find any issues and sent it back. I received the card and had the same issues so I told them I wanted a replacement so the they sent me a different card and still the same problem. What could be causing this?
 

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

We're going to need more information. Please include/list your specs like so:
CPU:
Moterboard:
Ram:
SSD/HDD:
GPU:
PSU:
OS:

Include the make and model of your PSU and it's age. Did you use DDU to uninstall your GPU drivers and then reinstalled with the latest off of AMD's support site? Installing the drivers in an elevated command, i.e, Right click installer>Run as Administrator?
 
Sep 2, 2020
3
0
10
0
Ty! And
CPU: i3 9100f
Motherboard: MSI B360 Gaming Plus
Ram: 8gb oloy ram@2400(was 16 one stick died. Tried contacting them at first they blamed it on Covid then they stopped responding. Need more ram lol. Don’t buy from Oloy.
SSD: ADATA SU 630 480gb
GPU: Gigabyte Rx 590 rev2
PSU: Thermaltake Smart Series 700w
OS: Windows 10 home 64bit

All the parts were purchased around January. Yeah I used ddu from safe mode and used the latest drivers from amd’s website. I’m sure I’ve tried running the driver as administrator but just to be sure I’m gonna go try again.
 

ASK THE COMMUNITY