Question Poor performance from 12900F i9

Wizerbwski

Distinguished
Aug 11, 2015
27
0
18,530
0
Hi all,

I have a new PC with a 12900F i9 CPU.
I think its bottlenecking the system at the moment as I cant get it to go anywhere near its turbo boost frequency of 5.1Ghz, it lingers around 2.4-3.4Ghz.

This chip is new and is watercooled by a 360mm MSI AIO.

Any help getting the CPU to run faster would be fantastic :)

System specs:
i9 12900F
32GB DDR5 Corsair Dominator
1200W Corsair PSU
MSI Tomohawk WiFi 690 MAG Motherboard DDR5
MSI RTX 390ti

Turbo boost 3.0 is enabled in BIOS.
 

Wizerbwski

Distinguished
Aug 11, 2015
27
0
18,530
0
Yes, ok good point. Temps are around 40 degrees.

I wonder if this:

The "f" model does not support overclocking so I cant artificially increase frequency, only rely on Intel Turbo Boot 3.0.
so am I right in thinking, because this is a 16 core CPU (8 Performance and 8 Economic cores) that because there are so many cores available the frequency stays low because it has so many cores to do the work, and equally increase frequency if the number cores are reduced?

Would disabling E cores increase speed/performance?
Similarly would reducing P cores also increase speed?

Or I have I bought the wrong CPU for gaming??
 

Eximo

Titan
Ambassador
F does not restrict overclocking, the lack of a K does. There are KF processors. F just means you don't have integrated graphics.

If the temperatures are low enough and you give the system a load, you should see higher frequencies. Have you just been looking at task manager while sitting on the desktop? It could be that the low frequencies are a result of a lack of cooling, which is in turn keeping the CPU artificially cool.

Try a benchmark like cinebench and see what it does. Check the performance settings in Windows. And you may need to do a deeper dive in the BIOS, just turbo boost enabled is not all of it, you have to look at the C-States, power limits, and core settings. Everything on auto might not be the way to go (Though I wouldn't expect so)
 

uWebb429

Estimable
@Wizerbwski

If you want maximum performance out of one of these CPUs you will need to increase the turbo power limits in the BIOS. The default 65W value will cause severe power limit throttling during any full load stress test. Look for PL1 and PL2 or long and short power limits in the BIOS. If you cannot find these, use Intel XTU or ThrottleStop to access these limits.
 

jeremy0118

Honorable
Feb 29, 2016
164
15
10,615
7
@Wizerbwski

If you want maximum performance out of one of these CPUs you will need to increase the turbo power limits in the BIOS. The default 65W value will cause severe power limit throttling during any full load stress test. Look for PL1 and PL2 or long and short power limits in the BIOS. If you cannot find these, use Intel XTU or ThrottleStop to access these limits.
Yeah exactly what i just said. Unlock the power limit and you're gucci!
 
Reactions: uWebb429

Wizerbwski

Distinguished
Aug 11, 2015
27
0
18,530
0
Hi all, thanks for the help so far. I have found the long and short power limits but they are greyed out and Im unable to change, that said they are showing 4096w for both? yes the CPU is still throttling.
 

uWebb429

Estimable
@Wizerbwski

Try running ThrottleStop.
https://www.techpowerup.com/download/techpowerup-throttlestop/

www.imgur.com
Post a screenshot of the main window, the FIVR and TPL windows while your CPU is loaded and throttling. You can also have a look in the Limit Reasons window to see if any reason for throttling is lighting up red. There should be a clue somewhere in this info.

It is possible that your BIOS is not setting up the CPU turbo power limits correctly. The ThrottleStop TPL window will show this info.

The largest value that the power limit register can be set to is 4095.875 W. If the BIOS or any software tries to write 4096W to this register, it will wrap around and the register will contain a value of 0 W. That would not be good. Hopefully the BIOS is not doing something dumb like that. Make sure you are using the latest BIOS version from MSI.

Delete the MSI Control Center software if you have that installed. Some versions of this software are buggy and can also cause the above problem with the power limits not being set correctly.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS