Question Poor performance from GTX 1070 with i7-6700K

Jan 16, 2022
5
1
15
0
Hi everyone.

Ever since I bought my GPU years ago it hasnt performed as videos from people with the same GPUs and the same CPU that post in youtube.

As a latest example, God Of War in 1080p with Original settings varies from 35 to 50 FPS. I see everyone else has above 60 FPS with the 1070.
Unigine Heaven works well with 2316 score 91.9 FPS, at 1080p

My PC has:

i7-6700K 4.00GHZ
16 GB RAM 2400 MHZ
MSI GAMING GTX 1070

What i have checked:

- Energy settings in both windows and Nvidia control panel are set to max performance.
- Removed all drivers with DDU and installed the latest ones again.
- GPU temperature is 68 C average

Any other ideas why this is happening?

Thanks in advance.
 
Last edited:

THpapi

Reputable
Mar 27, 2019
108
11
4,595
1
Hi everyone.

Ever since I bought my GPU years ago it hasnt performed as videos from people with the same GPUs and the same CPU that post in youtube.

As a latest example, God Of War in 1080p with Original settings varies from 35 to 50 FPS. I see everyone else has above 60 FPS with the 1070.
Unigine Heaven works well with 2316 score 91.9 FPS, at 1080p

My PC has:

i7-6700K 4.00GHZ
16 GB RAM 2400 MHZ
MSI GAMING GTX 1070

What i have checked:

- Energy settings in both windows and Nvidia control panel are set to max performance.
- Removed all drivers with DDU and installed the latest ones again.
- GPU temperature is 68 C average

Any other ideas why this is happening?

Thanks in advance.
Are you using any GPU tuner? Try dragging power slider up and leave voltage on stock, gpu fan up to 90%.
 
Cpu base and boost is the same. Might be overheating. Check cpu temperatures.
Check gpu temperatures too.
Your ram is running at 2133mhz. It's capable of 2400mhz. Enable XMP in BIOS.
Check if ram is running in dual channel mode. Use CPU-Z.
Post screenshots from CPU-Z - memory and spd sections (upload to imgur.com and post link).
 
Reactions: RodroX

THpapi

Reputable
Mar 27, 2019
108
11
4,595
1
Yeah ram was running in single channel instead of dual channel probably, and at a lower speed with worse timings most likely. TLDR bottlenecked by poorly optimized RAM
 

Nighthawk117

Notable
Sep 27, 2021
880
237
890
43
Hi everyone.

Ever since I bought my GPU years ago it hasnt performed as videos from people with the same GPUs and the same CPU that post in youtube.

As a latest example, God Of War in 1080p with Original settings varies from 35 to 50 FPS. I see everyone else has above 60 FPS with the 1070.
Unigine Heaven works well with 2316 score 91.9 FPS, at 1080p

My PC has:

i7-6700K 4.00GHZ
16 GB RAM 2400 MHZ
MSI GAMING GTX 1070

What i have checked:

- Energy settings in both windows and Nvidia control panel are set to max performance.
- Removed all drivers with DDU and installed the latest ones again.
- GPU temperature is 68 C average

Any other ideas why this is happening?

Thanks in advance.
A few dumb helpline questions if I may:

  1. Is the GPU in the top PCI-E slot?
  2. Is there anything in the second slot?
  3. Is your PCI-E interface running at x 16? GPU-Z will tell you this if you hover the mouse of 'Bus Interface'.
 
Reactions: RodroX

ASK THE COMMUNITY