Poor Skyrim performance

ToastWiz

Distinguished
Aug 5, 2012
19
0
18,510
Specs:
Intel i5 2310 @ 2.9 GHz (Quad core)
6GB DDR3 RAM
NVIDIA Geforce GTS 450 1GB
Windows 7 64-bit

I'm experiencing terrible performance in Skyrim, including both low fps and mouse lag. I've done some research and I've found that people are able to play this game almost maxed out with hardware older/worse than mine. I know I haven't exactly got the best computer but I should at least be able to play this game smoothly. It auto-detects that my hardware is suitable for high settings but that is a straight up lie.

I can play a lot of other games smoothly at high settings, including all Source games (that I've tried), Borderlands and Minecraft to name a few. Bethesda games, however, do not like my PC. I experience similar FPS in Fallout 3. Can anybody hint as to why I may be getting such poor performance?

 

ToastWiz

Distinguished
Aug 5, 2012
19
0
18,510

Lowering the settings does little to nothing, I'm still getting lag which I don't believe I should be for my hardware. Here is an example of somebody running Ultra settings with similar specs to mine: http://www.youtube.com/watch?v=inf4V2CZmjA
 
There is not really anything going on in that video and I suspect they must be running a seriously low resolution or just lying about the hardware as there is no way a 450 can run it in Ultra at 1920x1080. Anyway if you can even play it on Medium then there is another problem. Have you checked your CPU & GPU temps while gaming? Have you tried updating the driver?
 

ToastWiz

Distinguished
Aug 5, 2012
19
0
18,510
I can play it on medium but there is still serious mouse lag. My CPU stays at around 43 C and my GPU from 53-62 C. I have the latest drivers installed (301.42).
 

corymartin66

Honorable
Jun 3, 2012
333
0
10,790
you need to update your game to v1.6 or latter....if u are on v1.0 u will have very very bad performance...when i was on 1.0 i would get 35fps on med setting and now with the 1.6 update i can run it maxed out at 60fps
 

Optimus_Toaster

Honorable
Jul 22, 2012
458
0
10,960
I had a similar laggy feel in skyrim on my GTX 550 ti, despite MSI afterburner saying I had ~50fps, but when I added

iPresentInterval=0

to the [display] section of skyrim.ini (located in \Documents\My Games\Skyrim) the game felt much more smooth. It forcibly disables V-sync and stopped 50 fps being 30 fps.

I'd also advise following this guide from nvidia, to add some fps by toning down almost unnoticeable options:

http://www.geforce.com/optimize/guides/the-elder-scrolls-v-skyrim-tweak-guide/#1
 

ToastWiz

Distinguished
Aug 5, 2012
19
0
18,510

I tried tweaking the ini file by toggling the mouse acceleration to 0, to no avail unfortunately. I'll give this a try! Thanks for you help.
 

ToastWiz

Distinguished
Aug 5, 2012
19
0
18,510

This does seem to be the issue actually, I needed to update to 1.6. May I ask for your specs?
 

corymartin66

Honorable
Jun 3, 2012
333
0
10,790


GTX550 ti 1ghz oc
AMD Athlon x3 440 3.6 oc
8gb ram