[SOLVED] Port Forward rule in place but port not actually open

henry.live21

Reputable
Sep 17, 2018
4
0
4,520
1
It's a classic post, I know...
Let me put down the basics:
  • ASUS RT-AC66U B1 Router
  • Firmware: 3.0.0.4.386_48262
  • Router WAN IP is the same as external IP (ie not CGNAT)
  • Attempting to port forward for Home Assistant on RaspPi, port 8123
  • Rule as follows
    • Internal Port should mirror External Port if left blank (have also tried with 8123 in Internal Port)
    • 192.168.1.199 is the static IP of my RaspPi
    • Source IP is blank to allow access from any external IP
  • Rule is in place in the Port Forwarding log:
  • Router has been restarted multiple times
  • DMZ Disabled, AiProtection Disabled
However.....
  • Using web tools, port shows as closed
What am I missing - I am sure it is incredibly simple...
 

henry.live21

Reputable
Sep 17, 2018
4
0
4,520
1
Solved with a simple port conflict. These had been set up automatically and were causing 8123 to be blocked. I have changed the Home Assistant port to 9123 and it opens successfully.
 
There are generally three things that tend to cause this.
You do not have a public IP
You have the port forward rules wrong
The application is not actually active on the port or is using a different port.

You have ruled out the first 2, you could try DMZ just to be sure there is no stupid router bug in the forwarding.

This leave something wrong with the application. I forget the linux commands that show what applications are using what ports. You might also want to try access from the local lan, if that works then it has to be some strangeness. Maybe change the internal port to 80, that will only work if the raspberry is running a web server for access. It just shows the ISP is not blocking it more than anything else
 

henry.live21

Reputable
Sep 17, 2018
4
0
4,520
1
Thanks for the response.

  1. So I can access locally fine, I have access to everything internally.
  2. By DMZ, do you mean temporarily putting the RaspPi in the DMZ and giving it a go?
  3. I can try setting the internal port to 80, but obviously, the web port checkers are still telling me that the external port 8123 is blocking - I currently don't have a better way of testing the port forwarding at the moment.
 

henry.live21

Reputable
Sep 17, 2018
4
0
4,520
1
Solved with a simple port conflict. These had been set up automatically and were causing 8123 to be blocked. I have changed the Home Assistant port to 9123 and it opens successfully.
 

ASK THE COMMUNITY