[SOLVED] Port Forwarded (I Think) 25565 but still says it closed [NOT SOLVED]

Jan 14, 2019
23
0
10
0
Hello,

So as the title says i forwarded the port (I think i did) and its still closed i used canyouseeme.org to test if its still closed, and it is, im not sure what information to give you, i guess i can tell you what i tried

btw, i got this message in canyouseeme.org Error: could not see your service on [IP] on port (25565)

----What i tried----
Trying to forward the port
Disabling PC Firewall
I didn't tried disabling Router Firewall becouse im not sure how


i got a sky router and
I tried to forward the port with this tutorial https://www.youtube.com/watch?v=HlXqYDuyHXA&t=1s


I will answer anything you ask if you actually need it to help me
 

Ralston18

Titan
Moderator
On the router:

Did you set up a static IP address for the target computer?

The assigned static IP address should be outside the range of allowed DHCP IP addresses.

And should not duplicate any other existing static IP addresses on the network.

In addition, you should reserve that IP address via the target computer's MAC.



 
Jan 14, 2019
23
0
10
0


I should mention that im really really new to this port/public ip/external ip etc.

I think i know what is static IP address but im not sure how to check if i have it set up to the target computer (Im guessing the target computer is this one that i am currently using)

Im not sure what is DHCP IP and what do you mean you mean by outside the range ?

I think i never even set up a static IP, or maybe i did even not knowing that...

im sorry that i dont get that stuff, its my first time wroking with ip's/ports/static ip's/external ip's/internal ip's etc.
 
Jan 14, 2019
23
0
10
0
Its the Sky Q

I do have admin rights, i have the login and the password for the router to login into the web of the router

Im not sure if i still have it

Thank you for the user guide/manual but the router is working correctly the only thing is that the port is closed and doesn't wanna open even after forwarding it - im not sure if you get it or am i just missing the point (Im guessing im missing the point becouse i am the new one here)
 

Ralston18

Titan
Moderator
Port 25565. For Minecraft - correct?

Check the following link and thread:

https://helpforum.sky.com/t5/Broadband/Ports-are-saying-closed-even-after-forwarding/td-p/2874472

And here is a link that will provide you with a "big picture" look:

https://www.techadvisor.co.uk/how-to/network-wifi/how-port-forward-3591428/

Do not immediately start changing things.

Work out what you believe to be the correct configuration where all of the settings "fit" and make sense to you.

Then set it up and try again. Keep step-by-step notes about what you do and the settings you change.

 

molletts

Distinguished
Jun 16, 2009
475
2
19,165
145
Have you actually had someone test whether it's working by connecting from elsewhere using your public IP address?

canyouseeme.org is probably only testing whether TCP port 25565 is open. Games, in general, don't tend to use TCP ports - they normally use UDP ones instead - so even with a Minecraft server (I'm guessing that's what you're trying to get working as 25565 is the default port for MC) running, tcp/25565 is likely to show as closed, even if udp/25565 is listening. It's not normally possible to test whether a UDP port is open or closed - the only way to be sure it's open is to try using it.

I'm not familiar with the Sky router but most home routers allow you to convert a "floating" DHCP allocation into a fixed address (reservation), usually by clicking through from whatever page on the router's interface shows the list of connected devices to get to a settings page for the specific device (your PC in this case).
 
Jan 14, 2019
23
0
10
0
Correct

So i checked it and i think this problem that you gave me with the sky forum is about the game itself and not the ports but the guy that was helping the other guy said this : http://prntscr.com/m71sjj and now i forwarded the 3389 port but he said to forward it to windows firewall too, and im not sure how to do it, is it the thing that you go to inbound settings and add a new rule ? just making sure and if yes, then do i do it in outbound too ?
 
Jan 14, 2019
23
0
10
0


I think i just got a solution, i mean it will not solve my problem but i think its becouse my pc is stationary, i can't conenct to wifi unless i get my phone out and plug it by USB and share my wifi from my phone to the pc, maybe its becouse of that, i hope its this one, and i hope i can fix it somehow, if not i got a laptop that can run it too.
 

molletts

Distinguished
Jun 16, 2009
475
2
19,165
145

It shouldn't matter whether the PC is on WiFi or connected by cable. (A cabled connection is better anyway, especially for gaming.)

Are you running a standalone Minecraft server or just using the "Open to LAN" option in the game? I believe that using "Open to LAN" will host the game on a different, random port number every time, rather than putting it on 25565.
 
Jan 14, 2019
23
0
10
0


No, im not using the "Open to LAN" option, i am using the forge server setup, and i just tried on my laptop and it doesn't work too, i tried it to make sure, and i know that cabled connection is better but i was moving not long ago and i can't find the cable that was connecting it to the PC, so i am using my phone as a internet sharing thing

 

Ralston18

Titan
Moderator
As stated by @molletts wired or wireless does not matter per se. Cabled is better being faster and far less likely to interference.

Therefore, focus on getting the port open in the simplest manner possible.

Find your cable so you can connect the PC to the router and configure accordingly.

Avoid the problems inherent wth wireless and/or tethering.

Once you know that the port is correctly working then you can address the other connection options.


 

molletts

Distinguished
Jun 16, 2009
475
2
19,165
145

That could well be the cause of the problem. Your phone is also acting as a router to share its internet connection so is almost certainly blocking the port. There's no easy way of forwarding the port on the phone (it can be done on a rooted Android phone using Linux iptables commands but that's way beyond the level of this thread).

As @Ralston18 said - make your priority finding your ethernet cable so the PC can be connected directly to the router. That may well get it working.
 

ASK THE COMMUNITY

TRENDING THREADS