Port forwarding from modem to router doesn't seem to work

Nov 16, 2018
8
0
10
Hello! We had an application that gives our sellers access to the server database everywhere. It connects with the public static IP and a specific port, but the modem of the ISP doesn't allow the configuration of the remote IP address, so basically it's open to everyone. At the moment we had a router connected to the modem, all the pcs are in the router network and almost all the function of the modem are disabled so that the router could provide better security. The only things left are the dmz that design the router as the receiver of all the traffic coming at the modem and the port forwarding toward the router IP. In the router I opened the port requested by the app, the remote IP is the one from wich the app is connecting and the destination is the address of our server. Now the app doesn't connect to the server, am I doing something wrong?
 
When port forwarding does not work, I normally start by checking the firewall logs. Open the logs of the both the modem and the router and see if there are any messages after someone attempts to connect to the server. This should help you determine where the connection is being stopped (assuming the boxes have decent logging functions).

If the modem is really so limited, I would consider putting the modem in bridge mode (if available). The modem would then become invisible and your router's WAN port would have the public static IP address. The only place you would have to do any configuration is on the router. Check your owners manual for more information.
 
Nov 16, 2018
8
0
10

Unfortunately the modem is also a router.


The modem doesn't have a log and on the other one I didn't see anything strange. I wanted to do the bridge mode so that the router would have our public static IP address but maybe I was doing something wrong because the router couldn't mantain the connection. Could someone explain me the procedure, please?
 

Very common and not surprising.


Generally, putting a modem or router into bridge mode is fairly simple. Somewhere in the settings (often in the advanced features) there will be a check box (or something) to select bridge mode. In this mode, all of the routing features are disabled and all traffic is passed on to whatever device is plugged into it. I would suggest plugging a single computer directly into the modem to set and test this feature. Once it seems to be working, then plug the line from the modem into the WAN port of your router. The WAN port should then receive your static IP address from your ISP if you have it set to DHCP. If you have set a private static address for the WAN port, then change it to your public static address or to DHCP.

In some cases the modem's configuration will not be accessible after being put into bridge mode (the modem no longer has an IP address) and the only way to get to it would be a factory reset (normally a button on the back).

For more specifics, I would suggest looking at the owner's manual for the modem. It can probably be found online. If all fails, you might want to discuss replacing the modem with your ISP. Some ISPs even let you use your own modem (assuming same standards, protocols, etc).

 
Nov 16, 2018
8
0
10

I looked every setting of the modem, but there is no check box for the bridge mode, there's another way?
We already tried many times to ask our ISP a modem change because this one isn't suitable fo us and every time they says we would have been recalled to start the procedure. Obviously they never did and the following calls are all alike.
 
With that modem, it is possible for your ISP to do custom software, but hopefully this helps ... " log into router, click on 'Local Network', scroll to bottom of page, select 'Bridged Mode', under Network Mode."

You may have to click "show advanced" in the upper right corner.
 
Nov 16, 2018
8
0
10
On the router? I don't have to set nothing on the modem? If the router is in bridge mode, it won't control the firewal and the port forwarding, am I wrong?
 
Yes, unfortunately Technicolor allows ISPs to do custom software on their modems. It sounds like your ISP has chosen to leave that option off. I would speak to them to see if there is anything they will do.

As another test ... does your router (not the technicolor) allow for remote administration? While I would normally keep that feature off for security reasons, you could try to turn it on and see if you are able to access the router from outside the network. If you are, then the modem is forwarding packets to router (which is proper, as it is in the DMZ) and the issue you have having might really be with the router and not the modem.
 
Nov 16, 2018
8
0
10
The ISP foolish us around and I am tired of loose time at the phone with them.
If I open the router, how will I try to access directly to it?
 
1. Turn on remote administration on your router.
2. Many routers will have you also select a port to use, pick 5050 or something (this is for extra security).
3. Call a friend (that is outside your network) and have them pull up a browser. Enter you public IP address with :5050 at the end (ie. 8.8.8.8:5050)
4. They will get a message that they can't connect (blocked by modem or ??) or they will get the router login page.
5. Turn off remote administration when your done.
 
Nov 16, 2018
8
0
10
Sorry for the long "afk". In the end, I couldn't resolve the problem and now that a specialist is coming, we hope that he can also resolve this problem. Thank you for all the time you spent helping me.
 

ASK THE COMMUNITY

TRENDING THREADS