Question Port Forwarding on TP-Link Archer C9

Mar 30, 2019
8
0
10
0
Hello!
I'm having trouble opening up a server for playing a game with friends.
I opened all the needed ports, however, the website https://canyouseeme.org/ can not connect to the port, neither can my friends.
I opened the ports on my router, turned off firewall, made exceptions in the firewall while turning it off, made sure I have a static IP and about anything I could find on the internet.
https://portforward.com can't help me any further than it already has.
My router is a TP-Link Archer C9
I don't have a modem, I do have an ethernet switch box (Netgear 5 port switchbox) but from what I can find on the internet, it shouldn't prevent me from doing this.
My PC is set up with a static IP, connected to the router via ethernet (into the switch box and then to the router), DMZ is off and the ports are open everywhere I can open them.
Looking through the posts here on the forums haven't been of any help so far, so I thought making my own could maybe help me towards fixing this problem.
Thanks for any replies :)
If you need any more details on this, please ask and I'll provide as fast as I can.
 
Does the ip on the canyouseeme site match the ip you see on your wan port on your router. More exactly do you have a public or private ip. If they do no match you have a private ip and will never get port forwarding to work.

You might try the DMZ option to test. This in effect port forwards all ports to your pc.

The program must be active on the port you are testing or it will not respond.
 
Mar 30, 2019
8
0
10
0
Sorry if I'm being a little slow here
I'm not sure where I can find the WAN port, but it is the same IP as is displayed on google when I search for it.
All the IP's I can find on the router site itself are local IP's or subnet masks.
The port is also closed (according to the website, at least) when the app that should be sending signal through it is open and waiting for connections.
I would like to keep the DMZ disabled if its possible to host a server without it, since (from what I can gather with limited reading about it on the internet) it seems to open the network to a lot of access from the outside, where I would like to just have this server running without all the other ports
Thanks for the fast reply man

EDIT: I found a little more info.
My internet has what I assume is an internal IP, since it starts with 192.168.x.x. This is dynamic, but will that effect the server connection when my PC's IP is static? This IP is not what is shown when googling for it, so I assume it has an alternate, public IP too.
 
From the router menu, select "network map", select "advanced", select "forwarding", select "virtual servers"

It should have your local IP address 192.168.x.x and the port you are trying to forward.

To confirm, run a command prompt session (windows "start", type "cmd" and hit enter) then type "ipconfig" and enter - should have a line "IPv4 Address. . . . . . . . . . . : 192.168.x.x" which is your IP address (be it your static IP or not).

This address has to match the virtual server entry or no-go.

A good check of this would be to use another device on your network and port-scan your 192.168.x.x address and see if the port shows up. If it is not working on your local network (e.g. iphone w/ the "iNetTools" app) then it is possible something else is wrong with your app or firewall configuration, and will not work from the internet either.

May be good to list what app or game you are trying to forward for additional help...
 
Mar 30, 2019
8
0
10
0
From the router menu, select "network map", select "advanced", select "forwarding", select "virtual servers"

It should have your local IP address 192.168.x.x and the port you are trying to forward.

To confirm, run a command prompt session (windows "start", type "cmd" and hit enter) then type "ipconfig" and enter - should have a line "IPv4 Address. . . . . . . . . . . : 192.168.x.x" which is your IP address (be it your static IP or not).

This address has to match the virtual server entry or no-go.

A good check of this would be to use another device on your network and port-scan your address and see if the port shows up. If it is not working on your local network (e.g. iphone w/ the "iNetTools" app) then it is possible something else is wrong with your app or firewall configuration, and will not work from the internet either.

May be good to list what app or game you are trying to forward for additional help...
Yeah, this is set up as it should be. The IPv4 IP, which I sat to static previously and made a reserved IP on the router menu, is the same as I put in the settings for the port I'm trying to open.
The game is Arma 3, but I figured it wasn't too relevant, since people seem to have it working fine with doing this and the setup in the game itself is very simple. I of course allowed the game to access the ports through my firewalls too.
 
Mar 30, 2019
8
0
10
0
Check this out, shows the ports needed for both Arma III and steam (possible you're missing the steam ports?) up to the 1 min mark, and at the 4min mark he downloads the port check tool from portforward and uses it in trial mode to check to see if it's working - hopefully it will help

View: https://www.youtube.com/watch?v=iVt5vJWNS68
I watched that video before but I think I might've missed the steam ports previously.
This may be a stupid question, but the router will only let me make a port range on the external port, while the internal port can only be one port. What do I do here?
Thanks for the response
 
Mar 30, 2019
8
0
10
0
Well I tried to open up for the steam ports too, but it doesn't seem to have resolved the problem sadly.
Thanks for the suggestion, it would propably have become the next problem if I didn't fix it anyway.
 

ASK THE COMMUNITY

TRENDING THREADS