Question Port forwarding stopped working for apparently no reason.

xerrox

Honorable
Jun 28, 2016
4
0
10,510
0
For a few years I have been occasionally hosting minecraft servers for friends from my PC. I have done my fair share of troubleshooting issues but now I can't figure out what to do. Yesterday it was working fine and I was playing with a friend, today port forwarding no longers works. I have tried rebooting router, disableing/re-enabling the forwarding rule, disabling firewall. My pc is on a static ip address so that isn't the issue. This has happened once or twice before but rebooting the router fixed it quickly.
Ok while I've been working on this I noticed something about not having a "real" public ip if the one in your router settings differs from the one google/other website tells you and I think this might be the issue. Could that have changed over night and is there anything I can do to fix this?
 
The public IP you are using could have changed. Some ISP they change fairly often other ISP people report are almost impossible to get changed without calling the ISP. This is why a program called DYNDNS exists so if the public IP changes the DNS entry will also be updated so you don't have to keep track of the IP itself so much.

Now I guess it could have changed from a public IP to a private one. I would think that is not very likely. If you had port forwarding before you must have had a public IP. Most people having issues never has a public IP to start with and you can never make port forwarding work.

In general if the IP on the WAN of your router is different than you see on sites like whatsmyip you can not use port forwarding. You can lookup what is a public IP and what is a private IP but I highly doubt the ISP would assign a public IP and then run NAT. They almost always assign private IP.

You should check the IP but I would think if it worked before it is likely just you now have a different public IP.
 

ASK THE COMMUNITY