Question Port forwarding will not work

Oct 15, 2020
3
0
10
0
Hi I'm trying to setup a Minecraft server it works on Lan but for some reason it will not port forward. I feel like I have tried everything I have setup a port forwarding rule typed all different types of of ports. I have it set to 25565 to 25565 with both TCP/UDP enabled. I have Xfinity internet with a Arris surfboard Sb8200 modem and google Wi-Fi. I have contacted Arris directed and they said why could not help me because you port forward from my router.

Fix Port Forwarding - Google Nest Community:
https://support.google.com/googlenest/t ... 4323?hl=en

I found this post which said I have to port ward to from my modem to my router and then to my server.
I Had a support session with google for 3 hours and they were not able to help. Please help me I have been trying to fix this for months. Oh by the way I am running my server on a raspberry pi 4 with 4 GB on Balena IO.
This is a link to what I followed to step the server.
https://www.balena.io/blog/how-to-creat ... th-balena/

This the error I am getting.

18.09.20 18:36:45 (-0400) wifi-connect Spider mode enabled. Check if remote file exists.
18.09.20 18:36:45 (-0400) wifi-connect --2020-09-18 22:36:45-- Google
18.09.20 18:36:45 (-0400) wifi-connect Resolving Google (Google)... 2607:f8b0:4006:818::2004, 172.217.11.36
18.09.20 18:36:45 (-0400) wifi-connect Connecting to Google (www.google.com)|2607:f8b0:4006:818::2004|:80... connected.
18.09.20 18:36:45 (-0400) wifi-connect HTTP request sent, awaiting response... 200 OK
18.09.20 18:36:45 (-0400) wifi-connect Length: unspecified [text/html]
18.09.20 18:36:45 (-0400) wifi-connect Remote file exists and could contain further links,
18.09.20 18:36:45 (-0400) wifi-connect but recursion is disabled -- not retrieving.
18.09.20 18:36:45 (-0400) wifi-connect
18.09.20 18:36:45 (-0400) wifi-connect Skipping WiFi Connect

Also I have my modem connected to my router through an ethernet cable and then my router is connected to a switch which my pi is connected too.
 

kanewolf

Titan
Moderator
Hi I'm trying to setup a Minecraft server it works on Lan but for some reason it will not port forward. I feel like I have tried everything I have setup a port forwarding rule typed all different types of of ports. I have it set to 25565 to 25565 with both TCP/UDP enabled. I have Xfinity internet with a Arris surfboard Sb8200 modem and google Wi-Fi. I have contacted Arris directed and they said why could not help me because you port forward from my router.

Fix Port Forwarding - Google Nest Community:
https://support.google.com/googlenest/t ... 4323?hl=en

I found this post which said I have to port ward to from my modem to my router and then to my server.
I Had a support session with google for 3 hours and they were not able to help. Please help me I have been trying to fix this for months. Oh by the way I am running my server on a raspberry pi 4 with 4 GB on Balena IO.
This is a link to what I followed to step the server.
https://www.balena.io/blog/how-to-creat ... th-balena/

This the error I am getting.

18.09.20 18:36:45 (-0400) wifi-connect Spider mode enabled. Check if remote file exists.
18.09.20 18:36:45 (-0400) wifi-connect --2020-09-18 22:36:45-- Google
18.09.20 18:36:45 (-0400) wifi-connect Resolving Google (Google)... 2607:f8b0:4006:818::2004, 172.217.11.36
18.09.20 18:36:45 (-0400) wifi-connect Connecting to Google (www.google.com)|2607:f8b0:4006:818::2004|:80... connected.
18.09.20 18:36:45 (-0400) wifi-connect HTTP request sent, awaiting response... 200 OK
18.09.20 18:36:45 (-0400) wifi-connect Length: unspecified [text/html]
18.09.20 18:36:45 (-0400) wifi-connect Remote file exists and could contain further links,
18.09.20 18:36:45 (-0400) wifi-connect but recursion is disabled -- not retrieving.
18.09.20 18:36:45 (-0400) wifi-connect
18.09.20 18:36:45 (-0400) wifi-connect Skipping WiFi Connect

Also I have my modem connected to my router through an ethernet cable and then my router is connected to a switch which my pi is connected too.
First thing I see is that you have IPv6 resolution. Maybe try turning off IPv6 on whatever host you are running that command.
 
Oct 15, 2020
3
0
10
0
Hi thank you, I tried turning it off and it did not work

Also I don't know if this helps but this is the error I get when trying to load into the server on a different WIFI.
 

gggplaya

Distinguished
Jan 27, 2011
1,262
111
19,490
19
Try a different internal and external port. Internal port would be 25565 obviously as spec'd by Balena. But you can make the external port whatever you want, like 5555 or something like that.

Then on your client type in your IP address and 5555 as your port. The port forward should redirect you to 25565.
 
Oct 15, 2020
3
0
10
0
Ok so I checked my external address with the 25565 port on a port checker which it said it was open but my server ip address with 25565 was not open so I asked my friend if he could join the server with my external address and he could!! I don't know why its working now maybe because I got rid of the port forwarding rule and ip reservation and then put it back but I did that before and it did nothing.
 

ASK THE COMMUNITY

TRENDING THREADS