Port of my Buffalo Ministation usb 3.0 broken

BlackBladerz

Honorable
Feb 10, 2014
3
0
10,510
0
hi, I got my issue on my Ministation HDD. Yesterday, when i pick up the HDD, the port of 3.0 USB is loosen. when I checked, the port jack of 3.0 USB HDD is stuck on my cable leaving the HDD . After 2,3 times trying to connect back, there's one piece of metal pin fell off from HDD. I've forward to computer expert at two different place and they say it could not be fix and I cannot retrieve the data inside my HDD. there's everyone knows how at least to get access on my data and replace the casing and port of my HDD?

my HDD model is Buffalo Ministation HD-PNTU3 3.0 USB with cable of SATA (if i not miskaten) been used for around 2 years
 

BlackBladerz

Honorable
Feb 10, 2014
3
0
10,510
0
may i know your recommendation of third-party hard drive enclosure? since I dont even know what actually is third-party kind of enclosure

P/S this is the pic of my HDD and the broken port for your reference

 

stellaj

Reputable
Mar 22, 2014
1
0
4,510
0
this exact thing happened to my hdd. could you get your information off?




 

markdean21

Reputable
May 6, 2014
1
0
4,510
0
Hi guys..i also have the same HDD and it also happens in me 2 weeks ago...
did you find the solution? pls share it...i also need to recover some files from my HDD :'(


 

JustinX

Distinguished
Aug 6, 2011
221
0
18,680
0
the same thing happened to me but i can still access the drive but the metal piece goes with the usb connector...i try to find ways to glue that piece of metal into place
 

lawayne

Prominent
Jun 6, 2017
2
0
510
0
I have this same HD and the same exact thing happened to me. Down to the port jack being stuck on my cable to the piece of metal falling off. I was in Europe and had all my photos and video on it. I bought a new external case and transferred the internal HD to it thinking this would be an easy solution. But it got worse. It now thinks it needs to be initialized which would then loose all data. I tried using Disk Utilities on my Mac and it says everything is ok. I was hoping it would rebuild the directory but it doesn't even try. Please tell me you found a solution to this problem.
 

happygal

Prominent
Jul 13, 2017
1
0
510
0


Did you able to get back your data?
 

ASK THE COMMUNITY

TRENDING THREADS