possible failing motherboard? No display, no usb input/very little power to usb, fans and other components receiving power

Aug 16, 2018
1
0
10
0
Recently my build has been being funky. It worked fine about a week ago before I moved apartments, but upon plugging it in at the new place, I have some issues. After troubleshooting I'm beginning to think its the motherboard that's at fault. I would just like any recommendations or thoughts on if my line of reasoning is sound.

Components:
MOBO - MSI 970A-G46
RAM - G.SKILL Ripjaws X Series 8GB 240-Pin DDR3 SDRAM DDR3 1866
CPU - AMD FX-8350
GPU - EVGA GTX 980 Reference
PSU - RAIDMAX RX-635AP 635W ATX 12V v2.3

List of troubleshooting:

GPU (because no display)
- tried resetting GPU in slot
- tested current GPU in another machine and it worked
- tested 2 other GPUs in my machine with no luck
Edit: Also tested on multiple displays

PSU
- tested with power supply tester, seemed to be getting consistent power, the numbers didn't look out of the ordinary

RAM
- tested both sticks individually in each RAM slot to see if it was a posting issue, but nothing changed

CMOS
- tried resetting CMOS a couple of times, such as leaving it out for a few minutes then trying again, tried booting with it out, tried leaving CMOS out and PC unplugged overnight, still nothing

HDD/SSD
- didn't really think these would have been the issue anyways, but I tested them on a separate machine and they seemed to be functioning fine.

CPU
- removed CPU and checked pins, I didn't think anything should have been wrong there as there was very little physical movement of the computer as I moved it. Pins were fine, so I replaced CPU in socket and made sure the cooler/fan was working fine.

MOBO
here's where I'm personally thinking the issue lies and here's my reasoning.
-power is running to everything throughout the motherboard (fans, USBs?, GPU, aka anything that has a physical component that I can tell is turning on just from looking and listening)
-usb's are receiving power (though possibly not enough?) I plugged my phone into them and my phone was able to charge through the ports, however my keyboard and mouse that have LEDs don't light up at all.
- ethernet port (which has the LEDs to indicate if it's receiving a signal from the cord) is not lighting up or showing indication that anything is plugged in.
- unfortunately, my mobo doesn't have onboard graphics
- also unplugged and replugged every possible cable where they should be (its been a perfectly functional build for the last 5 years with minor upgrades in the past, so it's not like this is an issue with new hardware).


Thoughts? Any insight is appreciated before I go about buying new components that might not be the issue.

 
I think you've done a pretty thorough job at trying to narrow it down....and I'm definitely leaning towards the MB.

One more thing you might do....being the keyboard and mouse lights don't light. I'm pretty sure that would be powered by the +5V USB line. You could check that with a voltmeter.

Pin Number Cable Colour Function
1 Red VBUS (5 volts)
2 White D-
3 Green D+
4 Black Ground

and if you don't see 5 V....and you already checked your PSU (which you said tested good).....I'm thinking it would almost have to be the MB.
 

Similar threads


TRENDING THREADS