Question Possible RMA?


Jul 20, 2019
Hi all, i have an I7-9700k, 32gb ram and a PNY 2080 GPU, i also have a Rift S VR system. On Monday evening i was using my Rift to play Assetto Corsa with some friends when the headset went blank (complete black screen) mid race however it was still tracking movement as when i took it off the image was moving with the headset on my monitor. I figured it was probably a malfunction with the headset and did the following steps:

Uninstall Oculus software and drivers
reinstall oculus

oculus detected the Rift and asked me to run through setup, i did that till it told me to continue the setup in the headset but the headset still remained blank.

I then tried different USB ports and also a different Display Port on my GPU but again no display in the headset (although Oculus passes the tracking sensor check)

I have also now fit a PCIE USB3 card but issue still remains

My daughters pc is an i5-10400 with a Radeon R9 so to rule other stuff out i plugged the headset into her pc, installed Oculus and it lit striahgt up and went through the setup fine.

This now puts the blame on my computer.

I have removed the 2080 from my pc and swapped in her Radeon and the headset lights up as it should.

I then put my 2080 into her pc but the headset remains blank.

This now leads me to believe that the GPU is the problem.

Here's the kicker though, the 2080 has 3 DP and 1 HDMI and my ROG gaming monitor works fine in all 4 ports, its only the Oculus that has an issue.

Games also seem to play fine when not in VR so i can't say the card doesn't seem to be defective other than with the VR system.

I have tried all the different USB ports on my pc and all the different display ports on the GPU. I cannot try different cables as the cable is a custom connector at the HMD that splits into USB/DP at the other end.

I'm not sure what to try next and if i were to try and RMA the card (its in Warranty till April 2022) how would i do so as they will likely plug in a monitor and it work fine?

Any help or suggestions are appreciated



What OS version are you currently on for your platform?

Prior to RMA'ing your card, see if you can try the following;
1| Make sure you've got the latest BIOS on your motherboard. Checking your current BIOS version would be a good guide for us and you, then cross reference if you need a BIOS update.
2| Manually download the latest drivers for your RTX2080 from Nvidia's support site, store it onto your drive.
3| Use DDU to uninstall your GPU drivers.
4| Reboot into Safe Mode
5| Manually reinstall your GPU's driver in an elevated command, i.e, Right click installer>Run as Administrator.

See if that helps.

Make and model of the PSU in your build?

Regarding the RMA, you should include all information into the email/phone call to the seller + PNY. I'd also include a video of the issue you're seeing. This should give them context of what you're dealing, give them some meat to the potatoes you'll be serving them.
Last edited:


Jul 20, 2019
Hi, thanks for the reply, i should have added in the original post, i am running windows 10 Version 21H1. Motherboard has the latest (released 13/07/2021) bios and i have already used DDU in safe mode to remove and reboot then downloaded the latest 471.41 drivers today while testing.

Aorus Z390 Master motherboard
32GB (2x16GB) Corsair Vengeance ram
PSU is a Corsair RM850i
PNY XLR8 2080 OC (twin fan)
3x nvme gen 3 ssd's (500GB Crucial P2 boot, 1TB WD SN750 and 2TB Adata SX8200 pro )
1x4TB WD Green HDD
1x6TB WD Green HDD
1x PCIE USB3 add in card


Jul 20, 2019
Just to update this, I emailed PNY last night explaining the issue and asked what their recommendation would be.

They replied this morning asking me for purchase invoice and serial number, I forwarded those and they replied with an RMA number and told me send it in no questions asked..

Being packed and sent to France tomorrow