• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Meet Stan Dmitriev of SurrogateTV on the Pi Cast TODAY! The show is live August 11th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Professional PC modder Mike Petereyns joins Scharon on the Tom's Hardware Show live on Thursday, August 13th at 3:00 pm ET (8:00 PM BST). Click here!

Question Possibly dead motherboard

Jun 9, 2020
6
1
15
0
Hey my system wasnt booting, no fan spin nothing apart from the mobo rgb lights i turn it around and see this really nasty scratch from the standoffs im gueesing its dead or did it not affect much?
Heres a link of the image as it wouldnt let me embed it https://ibb.co/600Hp54
 

Quanticriver

Reputable
Jul 1, 2017
438
63
4,840
33
hello, and welcome to the forums

As far as i can judge from your photo, that should not be an issue

as the pc has been running for a while, whilst attached to the case (is this correct?)

did you check all the connections (especially the 24 pins and the 4/8 pin cpu connector?)
 
Jun 9, 2020
6
1
15
0
hello, and welcome to the forums

As far as i can judge from your photo, that should not be an issue

as the pc has been running for a while, whilst attached to the case (is this correct?)

did you check all the connections (especially the 24 pins and the 4/8 pin cpu connector?)
Yuup checked absolutely everything even changed psu and not it hasnt been running at all, mainly tried to get any sort of fan spin, tried shorting the power switch pins still nothing
 
Jun 9, 2020
6
1
15
0
Sorry for reviving this thread, but just to make sure theres no way the cpu might be an issue right? as there should be at the very least some fan spin if that was it...
Thanks had some hope it might not be considering the rgb lights were turning on but oh well thank you again <3
right?
 

ASK THE COMMUNITY

TRENDING THREADS