• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Potentially a Dead Motherboard/ CPU

macl64

Distinguished
Jan 3, 2013
42
0
18,540
1
Hi Community,

A few days ago, my PC was being used and suddenly the monitor completely lost connection to the PC (all lights continued to appear on the PC - i.e. RAM, GPU etc.). All external devices also lost power. The PC was then switched off via the mains. Since then, the PC has been unable to boot.

A few things worth noting:
  • The PC was built very recently (about 3 weeks ago) with no issues
  • Every time I attempt to boot the PC, a distinct click sound occurs near the PSU. This click only happens once. I would need to switch the PSU off and then on again (and then press the PC power button) to hear the click
  • I have attempted to remove the RAM and GPU with no effect
  • I also attempted to switch the PSU for a PSU of an older PC. The PC still doesn't boot and no lights appear. However, I noticed two things after making the switch:
  1. The click noise is no longer present
  2. A small flash occurs on the motherboard. The flash only happens once. I'd have to plug the PSU out and then in again (and press power on the PC) to see the flash once again. The flash occurs on a part of the motherboard with the label "CPU" on it. Presumably this might indicate it could be a CPU issue. I'm also curious as to why this doesn't occur with the original PSU.
Any help would be greatly appreciated. Specs below. Please let me know if there is any additional information that would be helpful to provide.
  • Ryzen 5 3600
  • MSI B450 Tomahawk MAX AMD
  • Corsair 650W TX650M Gold
 

macl64

Distinguished
Jan 3, 2013
42
0
18,540
1
Greatly appreciate your response. That was my immediate thought too.

As far as I'm aware, the standoffs are on properly, but I'll check this.
 

ASK THE COMMUNITY

TRENDING THREADS