Question Potentially dying EVGA 2060 Super - - - - advice for diagnosing the problem ?


Dec 7, 2022
Hello , I have had some problems as of late with my computer , in particular it seems that my graphics card began to malfunction.
First of all system specs briefly:
Ryzen 3600x processor
Tomahawk b450m motherboard
16gb ddr4-3200 (running at the xmp 3200 setting , think i tried to run it stock btw and same problem)
Corsair CX 650m psu bronze rated
1tb nvme (wd black) and 1tb ssd i think SK Hynix brand.

The first sign of a problem occured when I installed a game called fifa online 4 (which is like a generic free version of fifa).
The game crashed I think if I am not mistaking with a Unreal Engine error ( I didn't think anything of it at the time since a buddy of mine told me the game was full of bugs and ran poorly) so I thought maybe the instance is in that one game. Then one time I was live on twitch and I had seemingly some GPU artifacts in hearthstone and I even clipped it here ( you can have a look).

However I didn't have those particular artifacts again or any artifacts for that matter in hearthstone.
I ignored the issue again and thought maybe it was a one time thing.
But then a few (maybe 2-3 months) ago I bought F1 Manager 2022. And that game CONSTANTLY crashed with a Unreal engine error.
I have wrote about the issue on the forum and that is the first time it hit me this card might be on its last legs after a lad told me this nature of a error may well be hardware related.
You can read the post here: < screenshot of the crash.

Other games ran fine and the time (namely PUBG , world of tanks , football manager ) and anything else I played.
However last week I started having constant crashes in world of tanks with the drivers crashing like this : View:

I tried numerous ideas to try to resolve the issue such as:
Removing my old drivers with DDU and installing latest nvidia drivers.
Reinstalling all the mentioned games and installing them on the second harddrive , verifying file integrity etc.
Running my ram without xmp at stock I think ddr4 2666 speeds.
Reseating the graphics card in the pci-e slot and even putting it in the other pci-e slot and also connecting it to a different power supply cable.
Checking system file integrity with the sfc /scannow command (as suggested in some forum). etc.

BTW worth mentioning the first time i tried to seat the card in the second pci-e slot it went with a black screen after it booted into windows (the first few seconds there was video but it then blacked out). I then again reinstalled my drivers with DDU cleanly and it booted . Recently it black screened briefly one time even in the first pci-e slot though it then recovered and seemingly ran fine afterwards.

I am so convinced the card is the source of the problem that I already ordered a new card btw on amazon as a replacement but I'd like to get a second opinion here just in case (I'll just return the card if this one can somehow be rejuvenated but I doubt it).



Corsair CX 650m psu bronze rated
How old is the PSU in your build?

As for your GPU, have you tried working with the discrete GPU in question on another known working rig, to see if the issue persists there? In doing so, you could rule out your platform being the root of the issue.


Dec 7, 2022
edit: sorry misread your post a bit
The PSU was bought brand new with the pc in early 2020ish (so just shy of 3 years).
Nope , dont really have a system to put the card into besides this one. 😕:unsure: