Power Button or mobo? Please help!


Dec 1, 2012
Hi Guys! I have a new build. I have past experience building comps, but haven't done so in a veeery long time. Kinda out of practice. So, I put everything together, pushed the power button, and... nothing...

I did the paperclip trick for the power supply, it worked just fine. I also connected the 2 power switch pins on the mobo with a flathead screwdriver, and the whole comp starts up beautifully, asks for boot disk (nothing installed yet).

At first, I thought that the power switch connector was backwards, even though I am pretty sure that green is positive and black is negative. So I tried switching them anyway, and it still didn't work.

On the face of it, it seems obvious to me that the front panel must be no good. However, before I RMA the case (hopefully NewEgg will just let me RMA the front panel only) I want your advice if you think maybe the mobo's JFP1 may be bad. Just for info's sake, JFP2 (for the speaker) has been verified to be working just fine.

Second question! Is there any way around RMA-ing the case? Other thank leaving the side panel open and using a flathead to start the comp forever? I only ask because one of the mobo screws is directly underneath the edge of one of the most gargantuan heatsinks/fans I could find. I'm using the Noctua NH-C14 CPU Cooler in dual-fan mode, and the lever that locks the CPU in place is waaay underneath the fan and won't be able to be released. Thanks you guys in advance! Everyone here is awesome!
Verify the leads from the case Front Panel, then verify the motherboard connectors as shown in the motherboard manual. If you have done that, it is more likely that the case is the problem than the motherboard. The ON/OFF switch on the case is a momentary switch, you could get one from Radio Shack or another electronics supply store ($2-$4), then you could install that on on your cases' Front Panel, if you don't want to RMA the case.