Question Power cycles on/off

Apr 27, 2022
2
0
10
0
Asus Z97a motherboard power turns on/off every 2 seconds but power stays on when all ram is removed. Tried new ram, same thing. I removed the graphics card and all drives, no change, so I can't get to BIOS. What do I check now?
 
Apr 27, 2022
2
0
10
0
What happens if you only use a single RAM stick on each slot ?
Thanks for the quick reply. I've put new and used memory in each slot individually, in pairs and all 4 slots, no difference. But when I remove all ram, the board and fans continue to run. Here are the things I've tried:

On power up there is no boot LED or VGA LED showing. The ram LED comes on then the power cycles off and repeats. The CPU LED comes on momentarily then goes out while the ram LED is still lit.
I've removed the GPU, no difference. I've used the HDMI and VGA outputs but the PC never finishes the POST so I can't get to the BIOS.
I've changed the CMOS battery and cleared the CMOS several times using the jumper.
I've tried old ram and the new ram in different slot combinations to no effect.
I've tries the EPU, MemOK, TPU, EZ XMP switch settings but no change
Removing all ram and the unit does not shut down and continues to run! The ram LED stays lit (obviously), the CPU LED comes on then goes out. There is still no VGA or boot LEDs.
Thanks for any suggestions you may have. I'm guessing that it's either the motherboard or the power supply. I don't have a spare power supply so my only recourse is to gently try and reflow the solder with a heat gun..
Thoughts?
 

ASK THE COMMUNITY