Power Outage, PC won't boot. I was even using a surge protector :(

Nov 23, 2018
1
0
10
0
Moved from the U.S. to Italy a few months ago. Thought I might have problems going from 110v to 220v standard, but I checked and my PSU could handle it. Haven't had any problems so far, but the power at my new house goes out frequently; the outside breaker will flip and shut off all power to the house. I have my PC plugged into a surge protector so I didn't think it would be an issue. However, it happened a few days ago, and when I go to turn it back on after flipping the breaker, it won't boot. I can power it on, but no beep and no power to the front LED power button on the case, no video to the monitor, but there is a red light on the mobo, all fans are spinning, and the keyboard and mouse are lighting up.

- So far I've checked the monitor and it's fine.
- I switched the HDMI output from the graphics card to the mobo, nothing happened.
- I took out the graphics card completely to see if it would boot, nothing happened.
- I checked the power cables to the mobo from the PSU, they were fine.
- Unplugged the system from the wall for a minute or two. nothing happened.
- Tried resetting the CMOS by removing the motherboard battery for 30 seconds. Nothing happened.

I don't think it's the PSU since everything is lighting up and getting power except the front panel of the case. I also don't think it's any of the cables because it happened after the outage, not after anything moved. I'm not really sure what to do now. I'm guessing I'll need a new motherboard? And it that's the case, how can I be certain that's the cause/solution? I'd hate to buy a new motherbard, rebuild my computer and find out it's still not working. I don't have any spare parts around to help me troubleshoot.

Case: Corsair Carbide Series 200R Compact ATX Case
Motherboard: MSI ATX DDR4 Z170A PC MATE
CPU: I5-6500
CPU Cooler: Cooler Master Hyper 212 EVO
Memory: Corsair Vengeance LPX 4x4GB
GPU: EVGA GeForce GTX 960 4GB
PSU: Corsair CX Series 600W Modular 80 Plus Bronze
Hard drive: SanDisk Ultra II 480 GB SATA III SSD
 

Similar threads


ASK THE COMMUNITY

TRENDING THREADS