Power supplies & SATA drives


Jan 12, 2006
I'm having a problem with not being able to see SATA drives in a system buit in an Antec Sonata case with their 380 watt power supply.

I have used two different motherboards in the case and have the same problem. If I put an IDE drive in the system it is recognized.

First motherboard was an Asus A7N8X-E Deluxe which worked fine with two drives set up in a RAID 1 configuration. Then the other day they just wouldn't be seen. Drives are seen on boot and in RAID utiliy but not in BIOS.

I also put a single, brand new out of the box SATA drive in the system and it failed to be recognized. I tried to load windows on the brand new drive but it says there is no hard drive.

I then stuck an Abit AV7 board in the case and have the same exact problems. When I put that board in, I put the brand new drive in first and did not install RAID or anything. Was going to try it as a single drive system but still was not recognized. When I try to load Windows XP, it say there is no hard drive in the system. But if I stick an IDE drive, that is recognized.

I've tried different cables, everything. Is it crazy to think it may be the 'SATA-ready' power supply.

Any ideas? I'm at a loss.



Dec 23, 2005
Some sata controllers will need to have the drivers loaded before windows will recognize the drive you may have attached to it. Windows will ask you to press F6 if you need to install a third party SCSI or RAID driver. You should have a gotten a floppy disk with your mobo that has the driver for your controller. Afterwards it should recognize the controller and drives you have attached to it.