Question Power Supply Help Please

Nov 24, 2020
3
0
10
0
Hey guys, I know trouble shooting is pretty hard without physically seeing things but I wanted to see if anyone has any idea. So currently I have a Seasonic 750 watt gold plus power supply. Recently I got ahold of the white RMX Corsair 850 watt gold plus power supply. So when I installed the new power supply, the motherboard RGB comes on like it's suppose to, but as soon as I hit the power button, everything turns on for a split second then shuts off. The motherboard RGB remains on as well as the ram RGB stays on as well. I hook my old power supply back up, not a single issue. I'm not really sure how to trouble shoot and see what is exactly causing the issue, or if I may have just got a faulty power supply.

System specs:

Ryzen 3700x
RTX 3080
32 gigs of 4x8 3600Mhz Ram
Asus Prime x570 Pro Motherboard
Seasonic 750 watt Gold plus
2TB M.2 Sabreant Rocket SSD
1TB SATA Samsung Evo SSD
 
Nov 24, 2020
3
0
10
0
You did change the psu cables? They are not interchangeable between brands and sometimes even models.
Thanks for the response. Yes, I did change out the cables as well. I will be honest, there was one sata cable hooked up to one of my hardrive (not the boot drive) that was from the old PSU, but I didn't think that would cause any issues. All the other cables were the ones that came with the new PSU.
 
I will be honest, there was one sata cable hooked up to one of my hardrive (not the boot drive) that was from the old PSU, but I didn't think that would cause any issues.
Umm.. yeah. That would cause a problem. You're lucky if you didn't fry that drive. Worst case, you could've started a small fire.

Boot drive or not, all of the drives that are connected are provided power when you turn the PC on. It's not like the drive only gets power when you use that particular drive.

Man... you messed up.
 
Nov 24, 2020
3
0
10
0
Umm.. yeah. That would cause a problem. You're lucky if you didn't fry that drive. Worst case, you could've started a small fire.

Boot drive or not, all of the drives that are connected are provided power when you turn the PC on. It's not like the drive only gets power when you use that particular drive.

Man... you messed up.
Thanks for the response, I'm a newer PC owner, so this was definitely not something I was aware of. Lucky, everything still works great so I lucked out lol. But from what you guys say, it sounds like that sata cable was definitely the issue. I appreciate the information, I will give it another shot tonight
 
Dec 10, 2020
1
0
10
0
I have a similar question. I bought 2 Enermax platimax 1350's off ebay brand new for about 100aud ea. Are they any good and can I use them in a newer build? I was thinking of building a good VR rig for the oculus to run at max and also to handle the newer games without breaking a sweat. From what I've read of the Enermax they seem ok
 
I have a similar question. I bought 2 Enermax platimax 1350's off ebay brand new for about 100aud ea. Are they any good and can I use them in a newer build? I was thinking of building a good VR rig for the oculus to run at max and also to handle the newer games without breaking a sweat. From what I've read of the Enermax they seem ok
Tier A. Very good deal.

Tier A • Recommended for high-end systems
( multi/single-rail switchable )
• be quiet! | Dark Power Pro 10 / Pro 11 / Pro 12
• Cooler Master | V Platinum 2019 [MPZ]
• Corsair | AXi (<=1500W / 1600W) - RMi - HXi - HX Platinum - Vengeance Silver
• Enermax | Digifanless
• NZXT | E

( multi-rail )
• Antec | High Current Pro [HCP] Gold / Platinum
• be quiet! | Straight Power 11 Gold / Platinum
• Bitfenix | Formula Gold =>650W - Whisper =>650W
• Deepcool / Gamer Storm | DQ-M (not V2 / -V2L)
Enermax | Platimax (1200/1350W) / Platimax D.F =>750W - Revolution D.F - MaxRevo 1350/1500W
• LEPA | MaxPlatinum 1050W/1375W
 

ASK THE COMMUNITY

TRENDING THREADS