Question Power switch not working on NZXT H500

Jul 22, 2019
3
0
10
0
I finished my build a while ago and found out that my power switches where not working.

The logo on my motherboard lights up as soon as I turn on the power supply, but the power switch just doesn't work.

At first I plugged my F_PANEL pin bundle thing into the wrong slot (no pins were bent, the pins on the board were in the exact same place). Second try, I moved the cable and put it into the right place, but it still didn't work.

I even tried short-circuiting the PWRBTN & Ground pins, but it still didn't work.

Have I broken something?

Tried some more things:
  • Took motherboard out of case and tested it again.
  • Took each ram sticks out and tried them out individually.
  • Took CPU out ( there were no bent pins on the back ) and re-socketed it.
  • Took out battery on motherboard. Waited probably about 40 mins and then put the battery back in.
After every test I tried shorting the pins again to see if it would boot.

The logo on the board lights up as soon as the board is given power. I also tried charging my phone through the usb port and that worked ( These two happened just by giving the board power, NOT after shorting the power pins ).

I never saw the error LED on the board light up to any colour.

Motherboard: ASUS ROG STRIX B450-F
Case: NZXT H500
CPU: Ryzen 7 2700
GPU: GTX 1060
RAM: HyperX HX432C16PB3K2/16
Power supply: Zalman ZM-700GT
 
Last edited:
Jul 22, 2019
3
0
10
0
Have you connected the 20-24PIN connector AND a separte 4/8PIN connector. Also make sure your power supply meets the required power usage for your new parts
Yes, I even took them out and put them back in, although the 24pin connector seemed to have one of the square pin things missing, not sure if that is a big deal or not.

Just tried plugging it into a monitor and nothing happens when I try turning it on on that either.
 

ASK THE COMMUNITY

TRENDING THREADS