Question PowerColor Red Devil 6600XT Issues

Feb 25, 2023
I'm working on a pc for a friend, he got a Powercolor Red Devil 6600xt for it, used, and has no way to return it. I've done a ton of troubleshooting on this thing, I'll try and recall all that I did in the form. I don't know what else to try at this point.
Computer Type: Desktop
GPU: Rx6600XT PowerColor Red Devil
CPU: RYZEN 3 3300x 4 Core
Motherboard: Gigabyte a520m
BIOS Version: (latest)
RAM: 16GB TeamGroup TForce CL16 3200 Ram
PSU: EVGA SuperNova 750GT 80+ Gold
Case: Not sure
Operating System & Version: WINDOWS 10 PRO (Up to date)
GPU Drivers: AMD Adrenalin Latest Driver
Chipset Drivers: (Up to Date)
Background Applications: None
Description of Original Problem: Some artifacting as soon as you open the desktop, just flickering occasionally. He reported a few games would play and others would crash stating a driver error, I tested with Heaven and AMD's built in stress test. The card would immediately crash on Heaven with a driver timeout error, AMD's Stress test began to work the first time, throttled the card up just fine, then there was a blip in performance followed by a driver error, then it went back to full performance for about 20 seconds, then dropped to nothing. I have not been able to get a successful test since then. At idle the card shows 0-50 mhz GPU clock speeds, but mostly 0-8 mhz and 0-50 vram clock speeds, but mostly 0-10 mhz. The card also shows 0 mV for voltage, and then will go to .663 mV. This will last for only a second or two, then drop back down. When this happens it will seem like the card is getting ready to ramp back up before the voltage drop and then everything will go back to 0. All of the temperatures for the card were around 32 degrees the entire time during testing other than when the card ramped up to full speed during the first AMD test
Troubleshooting: I've tried setting the power options for windows to performance mode, I've tried changing the performance presets of the card, both with the bios switch on the card and with the options on AMD software. I've uninstalled and installed the drivers for the card probably 10 times, including old drivers to see if maybe it was an issue with the current drivers. I've pulled the drivers from Power Color's website as well as AMD's website. I've deleted the drivers using AMD's cleanup software, before booting into safe mode with Windows Auto Updater turned off. I've turned off MPO. I pulled out the card and put it in my system, and still had the same issues. I've cleaned the card, applied new quality thermal paste on the chip as well as new thermal pads, this only resulted in dropping the idle temperatures 5c. I've made sure that Windows was fully updated. I'm really at a loss here. EDIT: I've also tried turning off CPU boost in the Bios as well as changing the XMP settings for the RAM, but with either option on or off it does the same thing. EDIT2: I Have reflashed the VBIOS on the card and to no avail. I'm not sure what else I could do at this point
I don't want to call the card a lost cause, but it seems like he was getting somewhat of a performance out of it, and now it's just not working right at all. I don't know what else I could check or do to the card or the system to try and get this thing working. I've seen bad cards but this one just doesn't seem like its that bad. I'm wondering if the card used to be used for mining and possibly the vBios was tampered with. Either that or Maybe there is a loose solder joint on the board, although upon visual inspection I couldn't anything glaringly wrong with it. That's really all I can think of, and I wanted to come here and see if I could get any advice or ideas to try before I went about trying that, as it's kind of my last option other than trying to heat gun the board lightly to try and reflow the joints.

Any help would be appreciated, I'm running out of ideas to try here, and since it's his first PC and he's more on the budget side of things I want to try and get him going again without being too discouraged from the hobby.
Feb 25, 2023
Sounds like it has been used for crypto mining; which probably means it was under volted with memory overclocked. The memory has probably become unstable. You could try lowering the memory speed.
I have already attempted to do that. The memory speed shows up on Afterburner and Adrenalin as 0 mhz. I'm pretty sure the card is cooked, and I'm sure it was used for crypto unfortunately. At this point me and the owner have chalked it up as a loss, but maybe someone has some magic trick lol.