[SOLVED] Powercolor RX570 supposed to be 8 pin but only has 6

josiseatter

Honorable
Jul 19, 2015
6
0
10,510
0
I purchased the powercolor red dragon r570 from a local pc store. This unit is supposed to take a 8 pin pcie cable. The first unit I got did but ended up being faulty. The replacement unit I got only has room for a 6pin... Can't find anything online about this unit having a 6 pin. Has anyone else got this unit who can comment?

Cheers for your time

Photos >
View: https://imgur.com/a/tFaQBwS
 

Lutfij

Titan
Moderator
There should be a sticker to designate an SKU for the card. To note, the reason there are SKU's is to differentiate a version of item in a lineup or series, and for inventory stocking purposes. So which one did you have prior to the current card?

Considering your card has a connector for a 6 pin and the PCB doesn't look like the connector was tampered with(i.e, the 8pin input was removed in favor of a 6pin input), I'm sure that the card is meant to work off a 6pin and came that way from the factory.

Edit;
Upon looking at the SKU for the current card and the site, the card is said to have a single 8pin input. You should return the card and make sure you have images of the prior and current card as well as the site on your phone in a tab, in case the seller argues that you'd tampered with it.
 

Lutfij

Titan
Moderator
There should be a sticker to designate an SKU for the card. To note, the reason there are SKU's is to differentiate a version of item in a lineup or series, and for inventory stocking purposes. So which one did you have prior to the current card?

Considering your card has a connector for a 6 pin and the PCB doesn't look like the connector was tampered with(i.e, the 8pin input was removed in favor of a 6pin input), I'm sure that the card is meant to work off a 6pin and came that way from the factory.

Edit;
Upon looking at the SKU for the current card and the site, the card is said to have a single 8pin input. You should return the card and make sure you have images of the prior and current card as well as the site on your phone in a tab, in case the seller argues that you'd tampered with it.
 

josiseatter

Honorable
Jul 19, 2015
6
0
10,510
0
Thanks for the reply. Exact same card and model got them both on the same day. Frist 1 took a 8 pin and also the website says it takes an 8 pin.
Installed and is working fine so I guess nothing to worry about. Just thought was strange... every unboxing of this model on youtube has an 8 pin
 

artk2219

Distinguished
Jun 30, 2010
489
43
18,890
30
Could also be a bios flashed RX 470, shouldnt really make a difference either way so long as thermals are in check since the RX 570 doesnt suck much power either. But its kinda a shady business practive if they sold you an RX 470 instead of a 570 without telling you its been bios flashed, again it should work exactly the same, but they should let you know. So I would check the numbers on the card to be sure, could also be an ex mining model.
 

ASK THE COMMUNITY

TRENDING THREADS