Question Powerline ethernet setup not working "Ethernet doesn't have a valid IP configuration"

Jun 13, 2020
8
1
15
0
I bought a D-Link Powerline kit so I can enjoy fast and secure wired surfing. The router is in another tenants room, so this was the best option.
I cannot get the setup working. In windows troubleshooting I get the error "Ethernet doesn't have a valid IP configuration"
I have reset my laptop to factory settings, as I've wanted to do this anyway for a fresh install for some time. The issue persists.
Note, the entire time, the 3 leds on the adaptor have been green (not sure about the one plugged into the router though. I'd assume if that one is red, mine would be too.)

I've tried the following:

Obtain IP address automatically
Inputted a manual IP address and dns
ipconfig /flushdns
ipconfig /release
ipconfig /renew - this failed "unable to contact your DHCP server. Request timed out."
netsh int ip reset
netsh winsock reset
Updated network drivers, was already up to date (device manager shows no signs of issues)
Reinstalled network drivers
Disabled then Enabled the ethernet entry in here: Control Panel\All Control Panel Items\Network Connections
Tried to restart the DHCP client service in Services. Failed as Windows did the classic "access is denied" to the sole user, administrator of the device




Information:
Windows 10
MSI GE72VR 7RF Apache Pro laptop
Killer E2500 Gigabit Ethernet Controller
D-Link Powerline AV2 1000 Gigabit Starter Kit
"Plug and play for easy setup" lol okay.

I've ran out of ideas, to the point where I am wondering if it's a region thing. Used to live in UK with this laptop. Now in Canada. Can't think why that would matter.
I feel my experience with networking is intermediate at best, so I require some assistance.
The room mate plugged my adaptor into a power block/extension and not directly into a wall socket. I feel this may be an issue so when he wakes up I will ask to have the router in my room. Other than all that, I may just return it as a faulty device. Bought it at London Drugs yesterday. $70.

Thanks,
Nexios
 
Jun 13, 2020
8
1
15
0
Yeah, the adapter must be plugged into a wall socket not a power bar.
Try re-pairing the set.
Sorry for the multiple edits. Ignore me. I got it working. I simply plugged both adapters into wall sockets, reset both modem AND router and waited a few mins. Fixed! Thank you!! :)
 
Last edited:
Jun 13, 2020
8
1
15
0
Never mind. I fixed it. Thanks for the help :)
I'll keep this post here and this comment in case anyone else stumbles across the same problem.

Fix
Ensure to plug directly into a wall.
Reset router AND modem.
Wait a few mins.
Fixed!
 
Reactions: RealBeast

ASK THE COMMUNITY

TRENDING THREADS